2

I just bought an Apple TV last night. I have it sitting directly underneath my Airport Express. I have 2 wifi connections on my Airport, one for my stuff and one for guests.

When I list the wifi connections in my Apple TV it sees both, however when I try to connect to either I get this message:

There was a problem connecting to the network.

Check your settings and try again. (-3906)

I tried with a bad password just to compare the difference and I get this message:

There was a problem connecting to the network.

The Wi-Fi password you entered is not correct. Try again. (-100)

So it can see it, and tell it is the correct password; but it will not connect.

My MBP, MPA, Android phone, Xbox, and guests' windows laptops have all connected to this airport without any problems.

It does work if I connect the Apple TV to the Airport via ethernet.

  • Try manually changing the encryption method on the router that the Apple TV uses to WPA2, and then rebooting both. – Jonathan Oct 21 '12 at 0:51
  • @Jonathan The security method on my Airport Express is already set to "WPA2 personal" I have also tried rebooting both. I find it very frustrating that these are both Apple products and I can't get them to play nice together. – JD Isaacks Oct 21 '12 at 2:42
  • this an be a problem with your router. – Thorbjørn Ravn Andersen Oct 21 '12 at 9:49
2

I have 2 apple tv’s. One wouldn’t work anymore. I went to Utilities, Airport Utilities and noticed there was a newer version available. Once I installed the newer version my apple TV finally worked. I don’t know if this will help anyone else, but it did the trick for me.

1

Unfortunately, my post was edited to the extent that its meaning was changed.

Try making sure that the encryption method used on the Apple TV is set to WPA2, and not "WPA/WPA2" or some other type of autodetection. I've experienced problems (with other devices) when connecting to WPA2 networks using that autodetection, and I was able to connect without an issue when manually setting the encryption type.

I can't leave this as a comment because I don't have the rep points.

  • Thanks Jonathan, I couldn't find that setting on my Apple TV. I changed my Airport from "WPA2" to "WPA/WPA2" and back again, neither worked. But then I called Apple support, and while I was on hold it suddenly connected. Funny how it happens like that, the tech support suggested maybe it was timing out and while I was just letting it sit while I was on hold it just fixed itself. I don't know, but I hope it stays working now. – JD Isaacks Oct 21 '12 at 23:07
  • Interesting...Well, glad to hear that it's working! – Jonathan Oct 22 '12 at 0:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .