I have a number of local Windows, Linux and Mac machines on my local LAN, but no matter what, Safari will not resolve them by name.

How can I get this to work as there is no "server" on my network? I use the machine names only without suffixes.


4 Answers 4


I've had success resolving Windows hostnames to IP addresses (from my iOS devices) by installing Apple Bonjour (using the "Apple Bonjour Print Services for Windows" download package) onto the machine I wish to connect to, and then suffixing the server name with .local.



on my iOS devices becomes:


These two steps work for me both within Safari, as well as via other iOS apps.

  • Appending .local to the hostname worked for me (Raspberry Pi web server). Aug 25, 2021 at 11:13

It's likely that the computers are using NetBIOS name resolution (aka WINS or occasionally SMB). This is used commonly for Windows file sharing, and is typically set when you enter a hostname for a computer. On Macs and Linux, it's not always broadcast, unless Windows file sharing is enabled/installed, but it typically is, so it's usually a workable option for small networks without a lot of fuss.

However, iOS devices don't use NetBIOS (since they don't do Windows file sharing, there's not a lot of point, and there may be licensing issues, I'm not sure). So unless you've explicitly set up DNS hostnames on your network, this is most likely why you can't address your machines by name from your iPad.

The best solution here is to assign hostnames using static DHCP on your router — because your machines most likely already use your router for DNS, you should be able to change your settings on the router without needing any changes on any of the machines. Most home routers have some way of doing this, but it varies from model to model. The basic process is to assign a DHCP reservation for each machine and add the host name (some routers might allow for a hostname based on MAC address, without a static reservation). Those host names should then be resolvable from all machines, including the iPad via DNS.

If you need further help with this, add some information about your router (although searching for an answer on Superuser might yield the information you need).

  • I have a Billion BiPAC 7301VGP. I've already gone into to the DHCP service and entered fixed hosts for all my devices, using their mac address, and naming the fixed host. this includes the ipad, my htc phone, my apple tv, and everything else. all the machines have been shut down a few times since then (power failures guarantee that) but some host name resolution still doesn't happen. for instance my mac (mountain lion) can't resolve my qnap ts209 by name in a web browser but it can ping it by name; my ipad can't resolve anything; my win7 pc can see my htc phone by name when I use certain apps.
    – frumbert
    Oct 22, 2012 at 23:25
  • @frumbert The DHCP server is likely not participating in hostname resolution. When you configure one in your DHCP server, it is only advising the computer that "this is your hostname". In some corporate environments the DHCP server works in tandem with the DNS server to set up ad-hoc hosts that are resolvable through the DNS service. Not all routers do this, however. Jun 16, 2015 at 18:45

You need to configure your setting in DNS for WiFi options.

Please check the link here.

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone.
    – nohillside
    Dec 26, 2013 at 11:02
  • I don’t believe that this answer is relevant to the OP’s question. He or she was asking about name resolution on a local network, which will not be helped by switching to Google DNS or OpenDNS.
    – bdesham
    Feb 11, 2016 at 17:52
  • @bdesham: I don't see how my answer suggest Google DNS or Open DNS.
    – Meet
    Feb 16, 2016 at 8:42

As far as I can tell, Safari on the iPad can't resolve local network names. This functions seems to be broken by a recent iOS upgrade

I still can browse by ip address. Is the ability to browse by local network names broken by the recent iOS upgrade or is there something wrong in my setup?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .