My Mac Mail has just started going on the fritz. I have a gmail account linked to mail and also a hotmail account. Both have warning signs and I cannot send or receive mail. They were both fine yesterday. I have not updated or changed anything.

I am running OS X 10.8.2 and Mail Version 6.1 (1498).

When I click on the warning sign for gmail to 'take it online' I get the following message:

Unable to receive mail. There may be a problem with the mail server or network. Verify the settings for account “gmail” or try again.

The server returned the error: The server “imap.gmail.com” cannot be contacted on port 995.

...And the following for Hotmail account:

Unable to receive mail. There may be a problem with the mail server or network. Verify the settings for account “Hotmail” or try again.

The server returned the error: The server “pop3.live.com” cannot be contacted on port > 995.

I've tried sending mail and it shows that both gmail and hotmail are both offline.

I have been on multiple forums with this problem and it seems the whole world is having the same problem with no fix.

I've already tried the following to no avail:

  • I've checked all my info is entered correctly.

  • Changing the 'incoming mail server' to IMAP.googlemail.com - this got rid of the warning sign but still, will not send or receive mail. The warning sign has now changed to a 'zig zag' sign next to gmail.

  • Changing the port number from 995 to 993.

  • Re-entering my password.

  • Deleting the accounts and re-adding them.

Nothing works. Please does anyone have a REAL fix for this?

* Cant add this comment for some reason? But here we go:

Hi there,thank you for your fast responses. I have tried restarting my router and mail.app to no avail. Apologies - an error in my copy/pasting, the port for IMAP is 993. I just tried your terminal command and got the following: imap.gmail.com: nodename nor servname provided, or not known. I just tried adding my gmail acc. on my sisters iPhone 5 and got the following: Unable to connect to SSL, would you like to try and connect without SSL? (Yes) and got this: The IMAP server 'imap.gmail.com'is not responding. Check your network connection and that you entered the correct information in the 'incoming mail server' field. Im sorry, I dont know what a VPN is.

Also, All of a sudden BOTH accounts just came back online and updated with new mails etc. I've 'essentially' not changed anything. I reset the app and the router well over 20 minutes ago prior to this. You'd think changes would be instant if that was the fix?

  • Have you tried to quit and restart Mail.app?
    – myhd
    Commented Oct 17, 2012 at 12:05
  • You mention both ports 993 and 995. The IMAP port should be 993 (995 is POP3), As for why 993 doesn't work, it could be several things. Try to restart Mail.app, the computer, modem, router. If that doesn't fix check if your ISP is filtering gmail and hotmail. Go to Applications -> Utilities -> Terminal.app type "telnet imap.gmail.com 993" (without quotations). If you see "Escape character is '^]'" that's good. If not -- something is filtering the connection. Try to connect to another ISP or try another device connected to your network. If you have access to VPN try to connect through it.
    – lupincho
    Commented Oct 17, 2012 at 12:08
  • for some reason i cant add my full comment?
    – Ash
    Commented Oct 17, 2012 at 12:25
  • comments are limited to 600 symbols, but you can add to your question
    – lupincho
    Commented Oct 17, 2012 at 12:30
  • 3
    Based on the error "nodename nor servname provided, or not known" it appears that there was a DNS problem, most likely with your ISP's DNS servers if your router uses these. If the same thing happens again, type the following in Terminal app: "host imap.gmail.com" (without quotations). If this doesn't return IP addresses, then it is a DNS problem.
    – lupincho
    Commented Oct 17, 2012 at 12:48

5 Answers 5


I went into my network settings and added google's primary dns to the list. The address is and it resolved my issue right away.

My home router was pulling something odd from my ISP, but everything else was still working. Adding Google's dns resolved it instantly!


The canonical fix for troubleshooting Mail on OS X is to run the Connection Doctor (it's slightly buried in the Window menu without a keyboard shortcut to summon it) to isolate whether you have a general network error condition or a specific error on one or more of the accounts.

Each mail account will typically have two servers - different internet ports and potentially different username / password / authentication details.

Once you can isolate a specific error message on a specific port to a specific IP address, you can begin to troubleshoot whether you have a configuration issue, a network reachability issue or a server issue.

The show detail button is helpful to log the exact transactions and communications between Mail and the server.

If you have a vexing problem, I have found that disconnecting the network connection and quitting Mail (or forcing a reboot while the network is off) will let you start Mail and disable all Mail accounts except for one and also check for a stuck message or two in the Outbox. File those away as drafts so that you can then run connection doctor, re-enable the network and systematically work on the communication needed between the Mail program and your mail server.


I have the same issue, i have checked all the settings, and set the ssl to 993 as supposed to. however when you are in the main client and you click on take accounts online inside mail, next to your account, you get a drop down menu that states.

There may be a problem with the mail server or network. Verify the settings for account “[email protected]” or try again.

The server returned the error: The server “server.yourwebhostingworld.com” cannot be contacted on port 143.

Notice that the port 143 comes up, my port is set to the correct 993 so there seems to be an issue or bug here.

guess will have to wait until its fixed, until then you can use unsecured only.


I've had this issue since upgrading to 10.8.4 and read the other day on the Apple site that more than likely what had happened was the draft messages were being stored on the remote server and a message with a stored draft had been already sent, but the server cache with the draft had not been updated… this was in regard to 10.5 so I figured that this issue must have been resolved by now. It didn't make any sense to me to begin with, but I fixed it by doing the following…

  1. Open Mail → Preferences → Accounts → Mailbox Behaviors
  2. Untick the Drafts setting to 'Store draft messages on the server'

Drafts: Store draft messages on the server

Also just for my own preference, I unticked the Junk setting to 'Store junk messages on the server.'

When I restarted Mail I was able to connect for the first time in about 3 days and all of my new e-mails were downloaded.

The connection doctor testing did nothing for me.


After a time this no longer worked either and I went back to using Thunderbird. I largely suspect (in my instance) the issue is that I'm running my own local DNS server and mDNSResponder keeps hanging when choosing between the OpenDNS servers for the web and the local DNS server for local files. When the order of preference for the DNS servers change, the Mail app can't find my mail servers so it crashes until I restart mDNSResponder. Thunderbird doesn't exhibit this behavior in my case.


Found this via a Google search and wanted come back and share what fixed it for me.

First a couple quirks I noticed:

  • Did all the usual DNS resets and tweaks on my router and on the laptop...no luck
  • Not only was Mail not working, but a security app I had (Witness) was not connecting
  • Checked the logs and was seeing the following: DNSServiceGetAddrInfo() failed, error = -65563
  • Don't know why but Thunderbird worked fine

Did a PRAM reset link and bam everything worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .