I have an old MacBook Pro lying around that a friend left with me. I believe it is the 4.1 model, it should be the last one before the Unibody models came out (can't access About This Mac and the serial number rubbed off as well). I knew it wasn't working before but I tried booting it up to see if I could get it working.

Anyways, it seems to boot up fine but the keyboard and trackpad seem non-responsive. It does say Remote Mouse in the top toolbar, I think my friend installed some software to use the mouse through her iPod, but I would think the trackpad would still work. Also, it's weird because it does search for WiFi hotspots and finds them and also when I press the power button the shutdown menu comes up. My friend mentioned there may have been a hard drive issue. Do you guys know what might be the problem and if it is fixable?

On a side note, I also have a 15" late 2008 (5.1) model that I use but the optical drive is broken. Would I be able to swap the drive from the broken Mac to my newer one?

2 Answers 2


It's likely that the controller for the trackpad and keyboard (I believe it's one chip for both) is dead. I had an issue where the keyboard and trackpad on an older pre-unibody model would become non-responsive, but the rest of the top case components were fine (power button, back light). It was tracked to a faulty controller in the top case, but the solution was to replace the whole thing.

iFixit sells replacement top cases, but they're rather pricey ($299.95 for the A1260-compatible part). You might be able to find a cheaper one used on Ebay or elsewhere. The repair itself is fairly straightforward.

Have you tried plugging in a USB mouse or keyboard yet? If the problem is what I think it is, that should work fine.


You can try an SMC reset or PRAM reset as well, this could reset the "potential" issue with the firmware caused by the remote mouse.

More than likely this is damaged from liquid or some other component failure. USB keyboard and mouse are another test to try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .