I recently reinstalled my MacBook from a time machine backup (because I installed an SSD) [*]. Now syncing my iPhone via iTunes doesn't seem to work anymore:

At first, it displayed "over capacity" by 3.4 GB (which makes no sense, as I haven't added anything)

Then, after deleting several apps from my iPhone, the "over capacity" message is gone, but syncing doesn't work:

  • At first, it appears to work normally, and the capacity bar starts to fill up green on the left (green = apps)enter image description here
  • Then, after it finishes, the capacity bar turns yellow: enter image description here
  • I'm trying to sync a few files (just one song, and a few books), but they all keep the sync icon and are grayed out enter image description here I can't access the files on my iPhone.

Also, my iPhone seems to believe that the last backup to my computer was in September (according to Settings > General > iTunes Wi-Fi Sync), whereas iTunes says, that the last backup was today.

How can I make the setup work again? I tried enabling/disabling "Manually manage music and videos" and "Sync only checked songs and videos", as well as "Sync Apps" etc.

Info: Mac OS X 10.6.8, iOS 5.1.1, not using iCloud - only backing up to this mac.

[*] as described in http://support.apple.com/kb/HT1427 -> Restoring data from Time Machine backups -> If you are restoring a backup made by a Mac to the same Mac.

2 Answers 2


After spending almost the entire day on this problem, I found the solution: I had to thoroughly re-install iTunes, using FineWine's step-by-step guide.

Here are the things I did before that, but which had no effect: - Tweaking every possible setting in iTunes - tweaking every possible setting on my iPhone - reinstalling the latest backup - reinstalling the backup from last month - reinstalling the backup from a year ago - deleting files on my phone manually - doing several iPhone hard resets - upgrading to iOS 6 (!) - and more


Not sure why this is happening. Maybe some changes on the device that were not backed up?

If your Time Machine backup (and iPhone backup residing in the Time Machine backup that you restored from) is current, you could just try restoring the iPhone from the latest backup.

You may have to restore your Music folder once again from the Time Machine backup (that you restored from) to avoid the new backup (after your Time Machine restore) from interfering.

  • I don't have the old backups from time machine anymore (I had to wipe my backup disk because of apple.stackexchange.com/q/66598/7501). So what I just tried is restoring from today's backup. No difference. Now I also resetted my settings on the iPhone (General > Reset > Reset All Settings). Still the same problem. Commented Oct 16, 2012 at 12:09
  • Got my September backup now by connecting the old HD (which was not touched since making the last time machine backup). Restored it, but still the same problem. Commented Oct 16, 2012 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .