Since yesterday, when i'm running my computer, it shutDowns after 5 seconds of running. In order to make it work, i need to press continuously the escape key so the popUp alert who close the computer can dismiss.

When the os is launched, if i let the computer sit without any input, the alert panel appears, and if i don't do anything, my computer shuts down after the alert panel has been shown for 2 seconds. So this is very annoying.

enter image description here

Strangest thing is, that it appeared the same way last year (between october and november), and it disappeared same way it appeared. I have tried to change calendar date and time, but it was unsuccessful.

My question is: What could cause this alert firing ? Can i get a way to catch the *$**%* process who send this? Of course i can re-install the OS, but that's out of the question.

I have googled it and it seems that nobody has encountered this. I'm on Lion 10.7.4 and running it on a macBookPro, but last year on snow leopard the same thing occurred. I don't think it's a virus since it should appear on lots of computers, but it seems to appear only on mine.

  • 1
    Welcome to Ask Different! Can you post a picture of the alert? – duci9y Oct 15 '12 at 14:06
  • how did you solve it last time? – nohillside Oct 15 '12 at 14:28
  • 1
    I didn't do anything, that's the strangest thing. It disappeared between december and january, but it wasn't as frequently as today. (it appeared only after some hour or long long minutes). By the way i can't post image since i don't have 10 put of reputation. Here's a link of the alert type: neowin.net/forum/uploads/monthly_07_2011/… – loic Oct 15 '12 at 14:31
  • Does it already happen on the login screen or only after you have logged in (and the Finder is visible)? In the second case, does it only happen for one user or for all? – nohillside Oct 15 '12 at 15:05
  • It sounds like to me that you have a faulty install of mountain lion! – Stephen Oct 15 '12 at 16:06

That window appears if you hit the power button, maybe your power button is faulty and thinks you are hitting it. This also would explain why this problem "auto-solved" itself without you doing anything (i.e. there was some dirt "triggering" the click, and it went away).

| improve this answer | |

I have this at my MacBook Pro 1286 and if I power it up and unplug the Keyboard cable everything works just fine. I will order another keyboard and see if this is really the problem. I will let you know ;)

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .