3

Ok, so this summer I was in Korea. I used a Korean SIM card in my iPhone 4S while I was there. I ended up losing my iPhone before I came back to the US.

I recently purchased an iPhone 5 and backed up all my stuff that used to be on my old phone. Everything works fine except when I text (for the first time) new contacts that I have recently added.

When I do this, their number shows up in the Messages App instead of their name even though I have their number and contact info saved in my Contacts. When I click on "add to contact list" in the Messages App and I choose the contact, it adds a +82 in front of the number. 82 is the country code for Korea. I don't know why it does this. Can someone please tell me how to fix it?

1

Go to Settings > Phone

Check that My Number is has been updated to your new number.

At times when changing SIM cards, the number does not update in this area. This will cause issues like you have experienced. I recently changed carriers (in the USA from AT&T to T-Mobile) and experienced a similar problem after swapping the SIM card in an unlocked iPhone.

See Apple Support for more information regarding swapping SIM cards.

0

Have you tried turning International Assist off? It should be under Settings>Phone. Numbers that were previously in the phone before your trip to Korea are functioning normally, correct?

  • Are you referring to Dial Assist? It's turned off. And yest other numbers are working correctly. – user32881 Oct 28 '12 at 4:18
0

Messages on Mac and iPhone will only display contact names if those contacts are in iCloud or on the local device. If you're pulling in google contacts without syncing to either of the above, you'll lose the names.

To fix - sync the contacts to your local device (phone or mac).

0

I had the same problem of phone numbers & not names to identify messages. I deleted the texts. Then clicked on new text. Found the name I wanted to send text to wrote text & sent. Now that name appears instead of number.

You must log in to answer this question.

protected by Community Mar 19 '16 at 13:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .