0

Ever since I updated to 10.6.6 a week or so ago I've wanted to use the Mac App Store but I can't sign in. The Sign in link and the sign in menu item neither seem to do anything. I'm signed into iTunes just fine, I can use my account on my Mac and iPhone.

I've tried erasing the contents of ~/Library/Caches/com.apple.appstore/ but that had no effect.

  • If you're using FruitMenu or Application Program Enhancer try disabling them - there's a bunch of people who are having this problem here: discussions.apple.com/thread.jspa?threadID=2710337 - if that's not it, can you give a bit more detail re: the menu items not doing anything? – glenstorey Jan 23 '11 at 3:30
  • I don't have either of those installed, and by not doing anything, I mean I use the Store menu, select "Sign In..." and it blinks in response to being clicked and nothing else apparently happens. There are no sign in dialogs anywhere. – Neth Jan 23 '11 at 4:23
2

Got an answer from the apple forum.

Sign out of iTunes. Log off, log back in. Then sign into App Store, after that, sign into iTunes.

Looks like everything works now.

1

This answer didn't help me with the same problem - sign in just doing nothing at all. It turned out to be Little Snitch, see:

http://app-store-sign-in.blogspot.com/2011/04/i-cant-sign-in-to-apple-mac-app-store.html

Hope this helps someone else who's been googling for hours too!

0

If you're on a family plan, make sure that another user is signed out before you try to sign in. I tried to sign in several times and it wasn't working until I realized that a different user was still logged in. Logged out of that account and signed in with mine. Afterwards, it worked fine.

-2

you will need to logout of every apple app store if you've got serveral accounts then try login with the computer thats having issues and youll see also i thought icloud was originally not gonna see or detect my login from my problem computer but but it sure as hell noticed fast also final thing with me since i have 2nd party security i entered my password and the numbers before doing anything else and somehow it registered my computer so keep that in mind type your original password in plus the numbers if you have it set up like i do then press enter it seriously shocked me! i wasnt expecting that to happen but did.

your welcome jonathan

  • 1
    I'm sure there's an answer in here...somewhere. Consider rewriting so it's not one long stream of consciousness. – Allan Jun 15 '18 at 19:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .