My Magic Mouse at work looses right-click functionality every day, although System Preferences says it's enabled. I usually leave the computer at the "Login window" before leaving, and authenticate again to resume the session the next day. When I do that, right-clicking doesn't work anymore. I have to turn the mouse off and back on again to re-enable right-click functionality. I'm running OSX 10.7.5, but the problem is present at least since I upgraded from Snow Leopard to Lion (an year ago, maybe?).

I've googled this issue several times, and many other people have similar complaints, but I couldn't find a permanent fix. Does anyone know how to solve that? It's driving me crazy!

I tried replacing the mouse, but the problem persists. So, I think the actual cause must be one of the following:

  • A problem with my iMac's bluetooth hardware
  • A bug on the Magic Mouse's firmware software
  • An on OSX bug
  • 1
    does a coworker have a magic mouse as well? I'd recommend trying another mouse for a few days to eliminate your computer and your OS as a variable .. I'm thinking it's the firmware in your mouse that's reverting to default (single click) and when you turn it off/on it takes your settings from your preferences and works correctly. However, if it happens with the loaner mouse the problem is with your computer... just a suggestion :) Oct 11 '12 at 18:08
  • I have a spare mouse at home and will try that, thanks.
    – bfavaretto
    Oct 11 '12 at 18:10
  • I'm having the same problem. I believe it may be related to the aftermarket Bluetooth USB adapter I'm using on my Mac Pro. Jan 12 '13 at 7:23

I just talked to German Apple telephone support. They fixed the problem for me! With fresh installs of 10.7.5 the problem is that two files are missing that are needed for the mouse. In my case I could get them from another computer I own that ran Lion and did have the files. To get to the files you need do this:

Go to /System/Library/LoginPlugins/BezelServices.loginPlugin

control-click that file and choose "show contents" now in the finder window navigate to Contents/PlugIns/

In this folder should be two files named AppleBluetoothHIDMouse.plist and AppleHIDMouse.plist

If you don't find these files, you need to get them and put them in.

  • Thank you! I will try that, and report back. Might take a couple of days, since I'll have to copy files from my home computer to the office computer.
    – bfavaretto
    Jan 28 '13 at 17:00
  • WORKED! I already had those files, but replacing them with copies from my hime computer did the trick. Thanks again!
    – bfavaretto
    Feb 1 '13 at 17:40

I ran into this problem as well - I have a magic mouse and a trackpad which i keep in a drawer when not in use. My issue was a persist problem with the magic mouse LEFT click not working.

It turned out that some of the contents of the drawer were pressing on the trackpad and engaging its 'click'. Once I turned off the track pad, the mouse started working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .