Here what happened with me today. TimeMachine asked me whether I want to set a backup disk, I've answered yes, but then, when I've realized that in order to backup anything TimeMachine will clean the disk, I've changed my mind and canceled everything. And my disk suddenly became read only.

What I've tried before Googling:

$ sudo chflags -R nouchg Elements/
$ sudo chmod -R a+w Elements/

But I've failed with both of this, getting "read-only file system" messages.

What I've tried after Googling:

  1. Open Disk Utilities
  2. Click Repair Disk Permissions

But this button is disabled, and I have no idea what exactly should be done to enable it.

I have been using this disk for a quite a long time, and never had any permission issues with it. (Disk is formatted as NTFS, if that helps. Capacity is 2TB, of which 1.92TB are available.)

I'd really appreciate if someone will give me a hint how this can be resolved.

  • Try booting from the Recovery HD and see if the button is still disabled.
    – rien333
    Oct 7 '12 at 14:07
  • What exactly is it you need to do with the stuff on the NTFS disk?
    – segiddins
    Oct 7 '12 at 15:26
  • @SamuelE.Giddins I need to work with disk just as I've worked yesterday, 2 days ago, 3 days ago etc. It looks like very annoying bug to me - to find out that out of a sudden this disk is considered to be read-only.
    – shabunc
    Oct 7 '12 at 15:34
  • do you have any add-ons that would deal with file systems? if not, and you need to be able to write to an NTFS formatted disk, check out my revised answer. Otherwise, the disk has always been read-only, there is no built-in NTFS write support in OS X.
    – segiddins
    Oct 7 '12 at 15:36

You are getting the read-only file system error because on OS X NTFS is natively read-only. It was read-only before your Time Machine run in, and will stay that way unless you install a third-party driver, such as Tuxera NTFS.

Disk Utility's built-in repair commands are merely a GUI front-end for fsck and fsck_hfs. They are not meant to be used on an NTFS-formatted disk.

  • thank you for this response, but if they are not meant for NTFS-formatted disks, then, what should I do?
    – shabunc
    Oct 7 '12 at 15:15
  • Do you have a Windows install handy?
    – segiddins
    Oct 7 '12 at 15:16
  • nope, I haven't (
    – shabunc
    Oct 7 '12 at 15:18
  • This is great mystery why I've used to write to this disk previously, but it looks like you are absolutely right, NTFS is not fully supported on MacOS. Your answer gave me a hint, so I believe it should be accepted.
    – shabunc
    Oct 7 '12 at 16:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .