2

Dealing with numerous iPads (3G and LTE), all with the same telco.

If I go to Settings, General, Cellular Data Number, some iPads display the number fine (e.g. +11234567890).

On others, it shows "Unknown"

There doesn't seem to be any pattern or any rhyme/reason to it (e.g. iPad model, iOS version, SIM card age). Some show up, others don't.

The only fix I've discovered is to have the telco "push an updated profile" to it (not an "iProfile" - some sort of telco profile).

This fix works (after a device restart) but I'm wondering if anybody else has encountered this and found a way to avoid the problem in the first place?

  • I've had this issue on my iPhone and the problem was my phonenumber was not filled out on the SIM card. For some reason I was not able to edit it on the iPhone, so I put my SIM card in an old SE phone, edited my number, and the problem was resolved. – Gerry Oct 5 '12 at 21:32
1

This occurred when cellular data was turned Off. I turned it on and the number appeared.

  • Nope. I'm online now without a data number. – Potatoswatter Aug 12 '13 at 22:04
0

Tried all the above but still no joy. Then tried (make sure mobile data is switched on) settings -> mobile data -> mobile data options -> sim applications -> my number

:) hope this helps.

0

Ring your provider.

The phone number, & why it may or may not be registering correctly on your equipment, is entirely their domain.

They may have to send you a new SIM, or they may have to push a new profile from their end.
Either way, they're best placed to investigate it.

SIMs are not all 'equal'. Over time the firmware on them changes to accommodate newer devices & features. If yours is an older SIM, then replacing it might be the only option.

I had a similar situation on an iPhone 6S which was still using the SIM supplied for an earlier phone. Whilst it worked fine for the first couple of years, it then started dropping the line & generally being 'weird'. New SIM fixed it immediately.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .