38

I recently upgraded to Mountain Lion and all of a sudden my key bindings for Sublime Text 2 multi-selection editing are no longer working. Specifically, I had key bindings set up for Ctrl+Shift+Up/Down arrow.

Now Mission Control has taken over that key binding. How can I remove the Shift key augmentation (that causes the transition to be slower) for the shortcut?

39

You can disable the keyboard shortcuts for slow-motion effects by following these instructions:

  1. Open Terminal.

  2. Open the plist file in your user's library preferences folder that contains the setting by typing open ~/Library/Preferences/com.apple.symbolichotkeys.plist and hit return.

  3. A window similar to this will open in Xcode:

XCode PList Editor

  1. For items 34, 35, and 37, set enabled to NO.

  2. Close the file, click Save if prompted, and restart your system.

  3. Enjoy.

Note: 34 and 35 may not be present in the plist if you have never opened the Mission Control preferences pane and changed the "Mission Control" or "Application windows" settings. If 37 isn't present either, simply add it yourself.

This process has been tested with:

  • OS X Yosemite
  • OS X El Capitan
  • macOS Sierra

Source

  1. MacWorld
  2. In Translation
  • 5
    Odd. I only have 18 entries in that and keys 34, 35 and 37 are not among them. – Damon Feb 18 '14 at 18:41
  • Awesome! Works on Yosemite too :) – madzohan Oct 17 '15 at 20:35
  • 1
    I had to be explicit about opening in xcode: open -a "Xcode" ~/Library/Preferences/com.apple.symbolichotkeys.plist – Sam Eaton May 24 '16 at 23:03
  • Just logging off works too (no need to do full reboot if you don't want to) – A.Wan Dec 6 '16 at 1:38
7

You can disable the Ctrl+Up/Down shortcuts for Mission Control in the Keyboard preference pane. Just untick both "Mission Control" and "Application windows". This will also prevent the Ctrl+Shift+Up/Down key bindings, where the Shift key acts as a modifier to slow down the animation, as you have noticed.

screenshot of Keyboard settings

Disabling these shortcuts will allow you to use it again in Sublime Text 2 or other applications.

  • 4
    Yeah but I actually like having the Ctrl + Up/Down arrow shortcuts. I JUST want to disable the Shift key portion of the key combination. – Lester Peabody Oct 5 '12 at 19:05
  • @LesterPeabody I'm afraid you cannot only disable the shift portion of these keybindings. – Gerry Oct 5 '12 at 19:06
  • I see. Well, that's just totally awesome. – Lester Peabody Oct 5 '12 at 19:17
  • This should be the accepted answer. The accepted answer doesn't work if you don't have Xcode installed. – DrStrangepork Aug 29 '18 at 15:25
5

I am using Mavericks and opened the file in TextWrangler. Do not be shocked, it's in XML format.

Find the items 34,35 and 37 (check out Behrang's post) and change the appropriate tag to false (this is the same as changing enabled to NO ). Like so

<key>37</key>
    <dict>
        <key>enabled</key>
        <false/>

Now you can happily use the key combination with Shift and rearrange your bullets and paragraphs without starting the slow expose animation.

  • Thanks very much. I didn't want to install xCode just to edit a single plist. – Joel Mellon Mar 28 '17 at 19:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .