I just got a MacBook Air and wanted it to use my Canon ImageClass MF4370dn printer. The printer is on my network with a static IP. I've no problem getting MacBook to find the printer either via Bonjour or TCP/IP, but I can't get it to give the duplexing options that are built-in.

My guess is that the drivers I installed are not being picked up by the OS and instead it's using some generic driver. Any suggestions on how to diagnose and fix?

To be clear I'm using the latest Canon Drivers Version 2.4.1 for Mac OS 10.8. The only option that matters at all is having the silly thing duplex. I print up to 1000 pages a month, I need duplexing.


Mark Levison

  • Interesting inspired by some of the comments I played some more. All of a sudden 2 sided printing/duplexing is working when it didn't work before. I suspect a case of PEBKAC - funny thing is I don't what changed to resolve the problem. What do about the bounty? None of the suggestions below resolved the problem. Oct 18, 2012 at 19:25
  • 1
    having "read" the Canon documentation around these Mac drivers whilst trying to help you, I can see how the issue arose in the first place; the drivers are crap, and the documentation is even worse. As to the points, if you don't feel that any answer deserves the points, then that is your prerogative but you have already lost the points and you don't get them back. In your situtation, I'd award them to the poster whom you feel has given the best answer in the situation or whose assistance you felt at least helped in some fashion... even it's it not me :p
    – Stu Wilson
    Oct 19, 2012 at 13:24
  • Done. Strange as it may seem I don't really notice the points. Their only value was to give me a chance to offer a bounty to give the question more attention. In that case the value came because your answer caused me to try everything again and again. Now off to get my scanner to work :-) Oct 19, 2012 at 13:59

3 Answers 3


Have you installed the latest Mountain Lion ready drivers for the unit?

When you are adding the printer, what options are you using to choose the drivers?

If you choose "Auto Select" from the "Use" drop down that may be your issue.

If you choose "Select Printer Software" does the Canon software show?

enter image description here

enter image description here

enter image description here

  • thanks for the comment. This is exactly what I tried the first, second and third times. I even tried again just a second ago rebooting before I did anything. Oct 17, 2012 at 18:58
  • ...stack overflow cut me off... thanks for the comment. This is exactly what I tried the first, second and third times. I even tried again just a second ago rebooting before I did anything. As you can see in !http://www.flickr.com/photos/36331075@N00/8097753322/ the printer will print but I don't have access to any of the options I bought the printer for i.e. DoubleSided etc. <br>Double Bonus I don't understand MarkDown and images yet. Oct 17, 2012 at 19:06
  • I know what I want is possible since - Canon says in their docs: The default setting for [Print Style] for some printers that support two-sided printing is [2-sided Printing]. For information on changing the print settings to 1-sided printing, refer to change_default_Mac.pdf included with the driver download. Oct 17, 2012 at 19:11
  • from the help file, "if the printer driver name displayed at the top of the [Printer Information] dialog box and the printer name displayed as [Name Retrieved from the Printer] do not correspond correctly, you may not be able to use the printer functions correctly. "
    – Stu Wilson
    Oct 17, 2012 at 20:32

Try installing Canon's driver and then set the printer up as a new printer (delete the existing).

My Canon iR9065s, with Fiery GX300s, all have to have two-way communication enabled for all the extended functions to work (ie duplexing, staplers, etc); look through the Printer Features, there may be a field to specify (or search for and choose) your printer's IP.


Well, first of all, it's not clear what you mean by "I can't get it to give the duplexing options that are built-in." Duplexing is not necessarily a hardware or driver option on your printer; your printer comes with duplexing as a standard capability and it may be that the printer driver just assumes it. When you try to print something, is there a checkbox next to the number of copies that says "Two-Sided"? If so, then check it and you should get duplex printing.

If you don't get the "Two-Sided" option in the print dialog, then try switching drivers.

After you set up your printer, go to System Preferences -> Print & Scan, select your Canon printer and then click "Options & Supplies...". Then click on the "Driver" tab.

At this point you can try various drivers for the printer by using the "Print Using" option menu. Chose "Select printer software..." and search for applicable drivers and try them one by one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .