The trackpad button on my 2007 Macbook Pro seems to be sticking. Specifically, it's stuck in the "down" position, which means I'm selecting pretty much everything all the time (you wouldn't believe how frustrating it was just to ask this question). It was fine yesterday. What can I do to unstick it?

  • Can you determine if it's a software or hardware issue? What happens if you boot into the Mac OS installer, or some other bootable CD?
    – pgb
    Sep 1, 2010 at 20:16

6 Answers 6


The trackpad getting stuck is also a well known symptom of a bulging battery in the MacBook Pros of this generation. I'm dealing with this issue myself and am very annoyed about it too, because this 2007 Santa Rosa MBP I paid for is essentially the most lemon computer I've ever owned (at least four other hardware failures besides this one).

  • 1
    We appreciate your opinion, but the condescending vitrol really doesn't help. I had this problem in my second of four apple laptop's I've ever had, and there was other notable stress damage on the laptop (bulging case, etc.). Despite my laptop being well out of warranty, the Genius replaced mine free of charge. Problems happen, things go wrong, the company that gives everything away goes out of business. The unfortunate thing is, you quite possibly have the "correct" answer in this question, I admit. Feb 6, 2011 at 4:54
  • 1
    I'm happy you mentioned bulging batteries, thanks lkraav, very informative. I had enormous difficulties with the power system in my old 2007 MBP, that machine ate 6+ hard drives, 3-4 batteries, and 4-5 power supplies over 4 years. I never had the patience to let a battery bulge though, sounds like I made the right decisions Apr 25, 2012 at 20:26

This is going to sound dumb, but have you restarted the Mac? I've had this issue on my Magic Trackpad a couple of times and the only way I was able to cure it was with a simple restart. (At first I thought it might be because I also ran MagicPrefs, but I've since removed that and the problem still occurs sometimes).

If you find a restart 'fixes' it, as I have done in the past, then it's possible that it's the software getting confused rather than a physical issue. I haven't found a Terminal invocation yet to restart the mouse driver part of the Mac but I reckon that if I found one I could probably use that to unstick the pad when the problem arises.

  • As you read around, this defect is actually a very common problem in all Mac laptops and mac trackpads of a certain generation. It no longer occurs in newer models. Apple really should do a recall and repair, but that would cost them too much, I guess.
    – Volomike
    Apr 4, 2016 at 6:06

I had the same exact problem and it was almost unbearable to search for help. I took out the battery but kept my MacBook connected to the adaptor and, go figure, it works like a charm. Time for a new battery! The bulging on my battery is very noticeable.


In most models there's a screw directly beneath the trackpad that influences how hard/soft the click should be. If you have the right tools to open it up, you could try turning it a bit to see what happens.

What you can try first is to press down on the button, hold it down, move your finger from left to right a few times and then let it go again. Sometimes this fixes it, but if somethings really broken or worn it probably won't work.

  • I tried the loosening of the screw below the multitouch touchpad and it felt good clicking on it. Noticed battery was bulging right around location of the touchpad too. After screwing everything back in and testing ... one side of the touchpad is still extremely hard to press. Time to order a new battery and see if that resolves the issue. Thanks.
    – user22063
    Apr 25, 2012 at 8:01
  • What you can try first is to press down on the button, hold it down, move your finger from left to right a few times and then let it go again. Sometimes this fixes it... Thanks Alec It totally worked. Saved me a lot of frustration
    – user23290
    May 27, 2012 at 4:38

I've had an iBook g4 that had this "Issue"... it turned out a cookie crumble got stuck in the space between trackpad and case (don't ask). Clicking a few times on different places on the trackpad and some canned air fixed it. Might be worth a try before you pop out the screwdrivers.


I had something similar happen to my Macbook pro 2010. I fixed it by:

  1. Open system preferences
  2. Click Trackpad
  3. Uncheck Tap to click, Dragging, Drag lock, secondary click

Not sure if this is the same on a 2007 model.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .