One of the things I dislike most with the iPhone is its sized-down keyboard with only 10 keys in a row. This may fine for English, but leaves not enough room for umlauts or accented letters.

The official way to input umlauts is to hold down the key and wait until the umlauts and accented letters pop up, but this is way too slow. For numbers and symbols there is the tap-slide-release trick, but for umlauts this doesn't work.

Is there a way to type these letters faster?


I don't know a direct solution to your question: Reduced delay. If your iPhone is jailbroken you might be able to find the preference file that sets the delay and reduce it.

One work around could be to not deal with the accents at all and have the iPhone insert them for you, as autocorrected words. You can now type full speed.

To add custom words to the dictionary:

  • Add the Japanese Ten Key keyboard: Settings > General > Keyboards > International Keyboards > Add New Keyboard > Japanese Ten Key.
  • Add words: Settings > General > Keyboards > Edit User Dictionary.
  • Have the Word be what you want to type w/o accennts, and the Yomi be the accented work.

For example, I added Word=fooxx and Yomi=föoxx, I then went to the Notepad and using the English keyboard I typed "fooxx", and the iPhone suggested föoxx. When I did this example without the "xx" it did not work, perhaps because foo is already in my dictionary.

Alternatively, if you iPhone is jailbroken you could try using Xpandr

  • Cool! Is there a way to fix the words that the keyboard learned "wrongly", or do I have to reset the dictionary? – lpacheco Jan 18 '11 at 20:21
  • Not sure. I'd ask this as an independent question. – user588 Jan 18 '11 at 20:34
  • @ipacheco From my experience, english auto complete and auto correction is pretty good. Portuguese is not at all and really a hateful feature. I'd like to have it turned on for english only but since I can't I just turn it off. – cregox Jan 19 '11 at 3:00
  • @mankoff: Didn't know that you can edit the user dictionary like that! I tried your suggestion but it doesn't work for me (German keyboard, iOS 4.0.1). There is another problem with all dictionary based approaches: they work for words where the spelling without the umlaut is wrong. But in German there exist many words that are valid with and without the umlaut. And in Swiss German there doesn't even exist a spelling dictionary! – pesche Jan 19 '11 at 20:16
  • You need to add the Japanese Ten Key keyboard to be able to edit the user dictionary, not German. And yes, I agree, this solution is an imperfect hack with drawbacks. – user588 Jan 19 '11 at 20:24

What umlauts are you interested in? Could you switch to a keyboard layout which has them? I use åäö which are included in the swedish keyboard layout.

Apple provides several keyboard layouts for iOS. Just go to settings, general, International, Keyboards.

  • This is unfair. Just installed the Swedish keyboard and noticed that it has 11 keys in a row, not ten keys like the German or French keyboard. If the swedish keyboard had the ü umlaut instead of the å it would be usable also for German... – pesche Jan 20 '11 at 14:00

According to this Mac & i article iOS 5 will finally have a German keyboard with 11 keys in a row:

Edit: Only with iOS 6 this keyboard has finally arrived.

Tastatur mit Ümläüten


  • Unfortunately, this new keyboard didn't make it into the final release of iOS 5. – pesche Oct 16 '11 at 12:58

Worse : add the arabic keyboard, and you'll see that there's a key next to the spacebar that instantly pops up a choice of characters, when pressed. I, too, would like that kind of behaviour for accents in French ! I hate the one second delay.


Just want to inform everyone above that all you need to do is keep pressing the letter and all characters with signs above pop up, and there is the umlaut. I'm using 6s. Actually, just got it and needed the umlaut too.

  • 1
    Hi, welcome to Ask Different. The OP already knows how to get the umlaut, their problem is the speed at which the option pops out. – Jaime Santa Cruz Nov 14 '16 at 20:16
  • 5 years late and you apparently didn't read the question. Recommend you delete. – Tom Gewecke Nov 14 '16 at 21:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .