I'm running the latest iPhoto on a 10.8.2 Retina MacBook Pro and experience some strange import problems since the end of last month.

My library holds more then 26.000 images right now and whenever I try to import some new images by dragging them from Finder to the iPhoto library the images (and videos) get imported... but when I try to view the event afterwards it doesn't open and the scrolling of the complete events view is broken. The scrollbar moves but thumbnails of events don't! I'm not able to use the events view anymore after a try to open such broken event.

When I use the regular photos view (the 2nd item in the left menu) I can see and use these new images... until I quit and restart iPhoto. Afterwards many images are missing – see http://cl.ly/JrjF for an example. I can delete those broken events... but not empty the trash afterwards. It just hangs while purging all entries.

Has anyone experienced this already?

I'm importing iPhone images uploaded to the DropBox "Camera Uploads" folder. But I can't believe it has to do with anything related to this.

I've also disabled the Photostream feature (not the shared ones) in iPhoto because I got tired of splitted events due to Photostream missing some images now and then. Maybe it has to do with that disabled feature. I'll try to reenable it after restoring my 5 days old backup (120GB) a second time now.

Thanks for your help... let's hope I can solve this.

  • In the meanwhile I've tried to import those images into another completely new library and it worked... so I suppose the current library is broken, somehow. I'll try to rebuild it with iPhoto's own tools – using alt-cmd during startup. We'll see if this helps. Oct 7, 2012 at 17:43
  • I've tried all 4 options (cl.ly/JyW9 - german screenshot) but none of them solved it... :( Oct 7, 2012 at 21:02
  • I had to use a copy which was nearly a month old... all newer backups (TimeMachine) were already broken. I've lost no images because all new ones have also been uploaded to DropBox... so far so good! Oct 9, 2012 at 10:52


You must log in to answer this question.

Browse other questions tagged .