I have two Apple devices which flat out refuse to connect to our company WiFi, an iPhone 5 and a 'new iPad' (3rd gen). Both are running iOS 6. The iPad could connect while it was on iOS 5, but not since upgrading to iOS 6. When selecting the network, I'm prompted for the password, but once I've entered it (correctly) I get the message 'Unable to join the network "network name"'.

The company WiFi is run on Netgear WAG102 routers, using WPA2. My previous iPhone 4 had no trouble connecting even while running iOS 6. My room mate's iPhone 4S is connecting fine, though it's on iOS 5 still.

Any ideas what might be causing this? What can I do to troubleshoot and solve the problem?


I was also having iPhone 5 connection issues while running 2.0.16NA, but I was concerned about rolling all the way back to 2.0.7NA. I was able to connect by using 2.0.12NA. No other issues... so far.

  • 1
    Thans for the info regarding 2.0.12! I'll talk to our network admin to see if we can roll back as well. – Lizzan Oct 4 '12 at 6:09

I had this issue at work when replacing an older AP with a Netgear WAG102.

All devices like laptops etc connected fine. All mobile devices connected fine apart from certain apple iPhones. Possibly ones on IOS 6...

I solved this by doing the following:

Downgraded the firware on the Netgear WAG102. It was on the latest 2.16 I think. I reverted it back to 2.07.

I then changed the SSID to something totally random. Rebooted and all devices including IOS 6 connected. No issues.

I changed the SSID back to my company name as before and IOS 6 devices bottled out!

Sounds weird but I got mine working.

  • Thanks for the info! But what do you mean by "bottled out"? I'm not familiar with this expression. (English is not my native tongue) – Lizzan Nov 7 '12 at 7:37
  • @Lizzan I'm late, but for other users, we would use "bottled out" to mean "thought about doing it, but got scared" – Joe Jun 17 '16 at 14:44

We also have the Netgear WAG 102 wireless access points and I discovered something very interesting today. I have one WAG 102 that hasn't been updated to the latest firmware 2.0.7NA and my iPhone 5 can connect to it perfectly. The other access points that have been updated to 2.0.16NA and will not allow me to connect.

  • Interesting indeed, thanks for the info! I'll pass it on to our network admin. – Lizzan Oct 3 '12 at 6:00
  • Well, it seems like we're on 2.0.16 as well. I'll post if we manage to solve it. – Lizzan Oct 3 '12 at 7:13

WG102 Netgear access points will not work with IO6 on the iphone or ipad if you are using the latest firmware. Downgrade your firmware on the WG102 to an older one and it will work :)

  • Is there a guide somewhere on how to downgrade the router? – nohillside Dec 12 '12 at 18:37

Well, iOS 6.1 seems to finally have solved the problem for me; after updating my iPhone 5 happily connects to the company Wi-Fi again. I haven't yet tried connecting with the iPad, but I hope that works as well.


A fix I found for this is to choose 'Other...' when trying to connect to Wi-Fi and enter details manually. You'll know if it's worked when you click on the blue arrow at the side of the network name when connected and can see 'Forget this Network'.


When entering the "password" use the wep key (That long string of numbers and letters) Notice - this is a hex code - so the letters are from A to F and nothing beyond F - so any 0's you see are zero not the letter O.
Also - as I said - this is a hex key, I've noticed some mac devices (i phone 5 most recently) require a 0x in front of the key to let the device know the string is hex.

NOTE the 0x (lower case x) must immediately preceded the string (no spaces)- which is all upper case letters.

Good luck.

PS - We were using standard 128 WEP.

  • 1
    Thanks, might help someone else, but we're using WPA2, not WEP. – Lizzan Nov 13 '12 at 7:06

I fixed my problem by selecting "other" and typing in the SSID name. It works now. If a selected the same name form the list it would not work.


I also had a problem connecting to my Netgear AP, After I performed firmware downgrade to 2.0.7NA work perfectly now

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .