20

I have a 2011 MacBook Air with OS X Mountain Lion (I've upgraded from Lion). And ever since upgrading my escape key randomly stops working. And it's not that the keyboard on the laptop would be damaged as the same happens if I use Apple's Bluetooth keyboard. So I'm guessing it's a software issue.

Also in some cases pressing ctrl+esc achieves the same thing as just esc so I'm 100% it's not a hardware problem.

Does anybody have any idea what this might be all about and how to fix it?

edit: the escape key stops working completely but it starts working again after I restart the computer.

edit2: this usually happens after the computer wakes from sleep. So it's not like that is just stopps working in the middle of using it, but rather after I put it to sleep (or just close the lid) and then open it again.

Has nobody got the same issue? Is there a better place to ask OS X related questions than Super User maybe?

migrated from superuser.com Oct 2 '12 at 9:45

This question came from our site for computer enthusiasts and power users.

  • Stops working, as in "does not respond to any pressing"? Or works intermittently? – user479 Sep 25 '12 at 15:41
  • The first one. Then it works OK when I restart the whole computer. – Jan Hančič Sep 26 '12 at 6:36
  • You may have a hardware problem. I'd make a full backup if you haven't already, and take it to your local Genius Bar. – user479 Sep 26 '12 at 15:57
  • 2
    Have you tried using a different (empty/pristine) user account and tried to reproduce the issue there? It's possible some software runs in the background and breaks things for you. – Daniel Beck Oct 2 '12 at 9:30
  • 1
    @Daniel Beck I'll try to do that. – Jan Hančič Oct 2 '12 at 12:35

14 Answers 14

8
+100

If this problem happens in every application then it is indeed a system wide problem. If it only happens in one application it's an application problem.

This problem might also come from another (modifier) key getting stuck.

To check if the Esc key is ignored by the system itself or if another key is stuck use the Keyboard Viewer:

  1. Go to Apple → System Preferences...

  2. → Keyboard

  3. Enable Show Keyboard & Character Viewers in menu bar

Then when the problem happens again display the keyboard viewer and check if any keys are stuck. If not try using the esc key there and see if it displays as being pressed. If not then you probably have a driver problem.

You could then try installing your system on another drive and try to reproduce the issue on a clean install.

30

For anyone who ends up here after installing the macOS Sierra release candidate. I had to disable Siri and then kill the Siri process using Activity Monitor.

  • 1
    Had this problem after update to the public release of macOS Sierra, and this answer solved it. Less than optimal solution if you want to use Siri, I guess. – Markus Amalthea Magnuson Oct 7 '16 at 8:40
  • In my case Siri was hanged and restarting it solved the issue. thanks! – Daniel Pinyol Nov 8 '16 at 9:05
  • 1
    I had this problem too. Kind of annoying as I've disabled Siri (I disabled the Notification Center too via Terminal flag which means I can't run Siri anyway). Perplexed as to why it is still running when I've disabled it... – Matt Scheurich Jan 8 '17 at 12:45
  • 2
    I am on macOS Sierra (10.12.3) and killing Siri did solve the problem! – Pauli Feb 15 '17 at 9:35
  • 1
    Brilliant! Just killing the process worked for me! Thanks very much! – Chris Edwards Nov 22 '17 at 16:26
10

I've been having the same exact issue for a couple of weeks, and it did turn out it was indeed the Visor feature from TotalFinder as mentioned before by Joe. Disabling it did solve the thing.

Anyway, as it has been said, given the fact that the behaviour is the same with the built-in keyboard or the bluetooth one, it's obvious it's not a hardware issue.

  • Could you improve your or joes post by listing the version of TotalFinder that causes this bug / interaction? Is it perhaps a known issue or fixable by the TotalFinder people (for bonus points) – bmike Jan 16 '13 at 13:10
  • Thanks! I disabled and re-enabled Visor from TotalFinder and it works! Saved me tons of trouble :) – justnorris Jan 27 '13 at 13:32
  • Thanks for pointing this out. I never would have made the connection between my esc key problem and the TotalFinder Visor. Disabled 'Hide on ESC' and now I have my esc key back! – drebabels Feb 6 '13 at 7:38
  • Simply opening and closing the visor solved this issue. – Swader Mar 8 '13 at 12:21
  • In my case, it was a different program "WiD" (to connect to a wireless-display) causing ESC to not register as a keypress with any apps. Quitting WiD let it work again. (And while WiD was running, Ctrl-ESC worked sometimes, and fn-ESC other times.) Thanks for the hint of looking at other apps; since I didn't even try ESC for a long time after starting that particular app, I didn't make the connection at all. (And that app stays running after I disconnect.) – not-just-yeti Aug 28 '17 at 16:13
1

I wouldn't do a drive wipe and clean install just yet. I would first boot into safe mode. Do this by holding down the Shift key as soon as you hear the Apple "chime". See if you have the problem then. If the escape key works reliably, it is likely a driver or software issue that is interfering. You can remove apps or third-party drivers to try to figure out which one(s) are the cause.

If it still happens in safe mode, it might be time to do a drive wipe and reinstall OS X from scratch.

1

As others have said, there's probably some application conflict that's causing the issue (since you said it's happening with the built-in keyboard and BT keyboard). I was having this problem, too, with the same symptoms (happening after waking up from sleep, reboot solves the issue).

In my case I believe it's related to my use of TotalFinder, specifically the Visor feature of it. Bringing up the Visor and then hitting escape seems to recover from the failure until my Mac sleeps again. If you disable the Visor or uninstall TotalFinder, the escape key wont become lost in the first place.

1

Note that in order to solve this, you might not have to disable the Visor feature completely. I only disabled the option to 'Hide on ESC' and now I can switch windows between my terminal apps without sacrificing the option key

0

Wipe the hard drive and do a clean install of OSX.

I hate suggesting this, but it should fix your problem. I too had a weird glitch from upgrading my mac OS. (mine was that i couldn't empty the recycle bin normally- i had to use console commands) The apple genius bar was lost, google turned up nothing, and no "expert" had any idea.

I know a clean install isn't an answer to the problem, but it's a means to a resolution of it...

Feel your frustration, let me know if you try this and if it works :)

(apple will do a clean install free of charge, if you're uncomfortable doing it)

  • Perhaps, if you dont want anything as radical as a clean install right away, you could install on a fresh external hard drive. Boot from that, and see if the problem is there. I think though, that this type of issue will show up or not with a new user account, so I agree to try Daniel Beck's idea first. – David DelMonte Oct 2 '12 at 18:26
  • agreed.. I tried that with my issue without success.. external drive is a great idea.. good call :) – Ryan Hollingsworth Oct 2 '12 at 18:43
  • I should have said, that if this works, the OP will need to do a clean install afterwards.. – David DelMonte Oct 2 '12 at 20:29
  • Hmm, didn't know you can install OSX on an external drive and then boot from it. Will look into it. Clean install might not be such a bad idea, as the upgrade also messed with my PHP that I had. I'll just have to find the time now :) – Jan Hančič Oct 3 '12 at 8:49
0

The escape key on my Macbook Air was not working at all. I realized that the problem was that the Speakable Items Utility had assigned the Escape Key as the "Listening Key." Turning off Speakable Items (under Accessibility panel in System Preferences) seems to have fixed the problem.

0

DON"T REINSTALL YET: I had this problem. The keyboard viewer did not register "esc" presses. Turned out it was from turning on speech commands while playing chess. To fix it, I went to System Preferences --> Accessibility --> Speakable Items --> Listening Key. Then I changed the listening key to something other than esc, and the problem went away immediately.

0

For me, I'd to do the both.

  1. Disabled the TotalFinder hide on esc key
  2. And also changed the Esc key to something (i set it to backtik `)

Now it works.

0

I had enabled speech command in system preferences and soon after that the esc key stopped working. I tried several different fixes from forums before I realized it might be Speech command .Once I disabled this the esc key worked immediately. Go to System Preferences System Speech Speakable Items; Off

0

You may need to reset your SMC

http://osxdaily.com/2010/03/24/when-and-how-to-reset-your-mac-system-management-controller-smc/

Copied verbatim from the above blog post:

This is how to reset SMC on most modern Mac laptops, none of which have a removable battery:

Shutdown your MacBook Air / MacBook Pro

  • Connect the power adapter to the Mac
  • On the MacBook / Pro’s keyboard, hold down the Shift+Control+Option keys and the Power button at the same time
  • Release all keys and the power button at the same time – the little light on the MagSafe adapter may change colors briefly to indicate the SMC has reset
  • Boot your Mac as usual
  • Here’s the key sequence to hold down:

Reset the SMC of a MacBook Air or Retina MacBook Pro

  • Do keep in mind that by resetting the SMC you will lose power specific settings, like the time it takes to sleep a Mac and other customizations to power settings. No big deal, but if you have made many changes to your hardware behavior you will want to adjust stuff like sleep behavior again.
  • The boot time after resetting a machines SMC can be a bit longer than usual, that is normal.

Reset SMC of an iMac, Mac Pro, Mac Mini

  • Resetting SMC is different for non-portable Macs, but it’s still easy enough and the problems it addresses are the same. On any desktop Mac, here is how you reset the System Management Controller:

Shut down your Mac

  • Disconnect the power cord
  • Press and hold the Mac’s power button for 5 seconds
  • Release the button
  • Reattach the power cables and boot the Mac as usual
  • Reset the SMC of a MacBook or MacBook Pro’s with detachable batteries
  • sad mac reset the smc Older MacBook laptops, indicated by having a removable battery, can reset SMC with the following approach:

Shutdown the MacBook/Pro and remove the battery

  • Disconnect the power adapter, hold the Power Key for 10 seconds
  • Release the power key and reconnect your battery and power adapter
  • Turn your Mac on
  • Let boot as usual
0

For me, in macOS Sierra, with the Macbook Pro with Touchbar, ctrl + esc works, in vim. But nowhere else so far, such as escaping from a full-screen Chrome tab.

Unfortunately, killing Siri does not resolve this for me.

-2

Why not just briefly press the power button to wake from sleep like I do? No different from pressing a key.

Works for me!

  • This has not much to do with the escape key not working. – Saaru Lindestøkke Jan 19 '13 at 12:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .