At the moment I am in mainland China, using an iPad set to British locale. When I use the search field in mobile Safari, it always loads google.com.hk (not google.com or google.co.uk).

Unfortunately this version of google is often extremely slow or doesn't load at all here, most likely because of the Great Fiewall of China (clicking a search result also asks google's server first, therefore it also takes a very long time). In contrast, google.com works fast and reliably most of the time.

Is there any way to force mobile Safari to use google.com instead of google.com.hk in iOS 6? In iOS 5 at least it loaded google.co.uk, which also worked, but now it insists on google.com.hk, and the search settings only let me specify "Google" as search engine, but now a specific version of it.

(Note: I am new to iOS and still getting familiar with it.)

1 Answer 1


Perhaps not exactly what you were looking for, but if you load Google's main page and it redirects to your local version, you could force it to use .com just by tapping the button on the bottom of the page.

  • Thank for the suggestion. I have actually already done that, and I'm trying to get into the habit of always loading the main Google page first and searching from there. Unfortunately the built in search box still uses google.com.hk, even if I set google not to redirect to google.cn or google.com.hk.
    – Szabolcs
    Commented Oct 2, 2012 at 1:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .