Apple TV was working fine up until yesterday.

I had rented & watched Men in Black 3 and it was all good - that was my first day experience wi Apple TV - great!

Now it's all gone downhill...

Nothing changed on my network - connecting wired directly to my router/modem to the net.

Apple ID is fine as i've tested it on other iDevices.

I have the iTunes Store set to Australia with correct Time Zone.

I've got Home Sharing turned on with my Apple ID on the Apple TV and it's working.

The problems ...

When I try to Sign In, I either get (it's random) ... 'Unable to Sign In - Apple TV can't connect to the server at this time. please try later.', OR 'Unable to Sign In - The Apple ID you entered couldn't be found or your password was incorrect. Please try again.'

When I try to watch YouTube I get ... 'No content was found - There is a problem communicating with YouTube. Try again later.'

Funny thing is everything else works - Movies & TV Shows previews, iTunes Festival, Trailers, Vimeo etc.

* ? Any ideas guys?

FYI - I'm with iiNet (Australia).

Updated ...

Have cross posted here (there is a workaround included in the discussion now) - https://discussions.apple.com/message/19836260#19836260

  • I have got exactly the same problem in England plays everything but not YouTube .? – user43671 Feb 24 '13 at 11:32

This may sound weird, but, unplug the Ethernet and connect to your wireless network. You should have access to all internet services. Some thing happened with my ATV out of the box, but using wifi solved the issues. Apparently a bug with that version of iOS. Apparently they fixed it on the latest update but I never went back to Ethernet to test and it's been fine on wifi.

It's something to do with the relay back to Apple servers apparently, but seemed like a weird bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .