4

From my MacBook Pro, I use a Java program that allows me to remotely connect to my Windows computer. I use Outlook on this Windows computer where normally I use shortcut keys like ControlF2 or ControlF4 to categories emails in Outlook.

So for ControlF2 it actually works fine but I need to press fnControlF2. The issue is when I press fnControlF4 it seems that it's an Apple shortcut to rotate through apps, so it trumps what I am actually trying to do on the Windows machine.

Is there any workaorund to this issue? Is there a way I can turn off some of the Apple shortcuts or anything else to deal with this?

Update

I created a bounty to answer the question that I listed as a comment on the first answer:

What is weird is that F2 and F4 are both checked so I don't understand why F2 works but F4 doesn't in my Outlook. Also, after unchecking F4 and trying to categorize in Outlook the shortcut still doesn't work. After turning off all of the Apple shortcuts, it seems that F2, F6, and F8 work but others don't. Any explanation?

4

You can disable some of the F-key shortcuts in System Preferences: enter image description here

1
  • thanks . . what is weird is that F2 and F4 are both checked so i don't understand why F2 works but F4 doesn't in my outlook. also, after unchecking F4 and trying to categorize in outlook the shortcut still doesn't work. After turning off all of the apple shortcuts, it seems like F2, F6, F8 work but others don't . .any explanation ? – leora Sep 29 '12 at 15:32
3
+50

Just a suggestion: Look at the key mapping in windows and not the Mac side. remember that while Command is often control in windows, often times the option, fn, and control keys can be swapped.

3

Take a look at our application ShortStop which was made specifically for sending shortcuts through remote screen sessions.

1
  • Not only am I a big fan of your work, I appreciate the participation and self-disclosure that you are discussing your products. – bmike Oct 28 '12 at 22:28
2

It's not easy to test if it work without having your Java program and your windows environment.

However in Settings > Keyboard there is a flag Use all F1, F2, etc keys as standard function keys. If you check it you have to press fn+Fx for using the special features printed on the Fx keys.

Keyboard settings

On my system (Mountain Lion), when this flag is unchecked fn+control+F4 produces the effect you reported: rotate through apps. This is the shortcut mentioned in Lauri Ranta's answer. When I check the flag the keys combination doesn't produced the mentioned rotation. You can try to uncheck it.

If your problem persist you can try to remap shortcut under Windows, in this way you can assign the command associated to fn+control+F4 to another combination which is not used under OS X.

In this question on Super User they said that it's not possible to change Ctrl shortcuts under Outloook. However they suggest to use AutoHotKey to assign a script that sends Ctrl+F4 to Outlook when you press another combination of keys (which you can decide). Here you can find more information.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .