I installed Mountain Lion yesterday and have only one problem. Time Machine, which worked under Lion on a WD Sharespace network drive, not gives a message that it cannot find the drive. Despite that, it can "enter" Time Machine with no problem and read all the saved backups. Time Machine itself shows the drive as available to be selected for backup. Finder also sees the drive. Lastly, the Time Machine backup volume which never had been visible on my desktop under Lion is now always there under Mountain Lion.

  • 1
    This is one of the reasons you may want to use an officially blessed Time Machine destination. I fully understand why you've chosen as you did - but I've seen similar things before and for backups it is important that it works. Sep 30, 2012 at 8:07

1 Answer 1


My take from this Apple Discussion thread is that the solution causes Time Machine to create a full new backup rather than adding to the other backups, but previous backups will be kept (not sure of actual behavior). Anyway, here is the posted solution (edited formatting and grammar for readability):

By default, the WD Sharespace creates a hidden share called WD_Backup and a user called wd_backup with a default password of backup.

Using the example in the blog:

sudo tmutil setdestination afp://user:pass@host/share

and assuming the following: (all default settings with the exception of the WD Sharespace Server Name)

Server Name: TimeMachine

Volume Name: DataVolume

User: wd_backup

Password: backup

You should execute the following in Terminal:

sudo tmutil setdestination afp://wd_backup:backup@TimeMachine/WD_Backup

In addition, you can validate that you are using the correct User and Password details by:

  • Launching the Finder and clicking on 'Go' from the menu

  • Clicking on 'Connect to Server...'

  • Entering: "afp://TimeMachine/WD_Backup" in the Server Address field and clicking 'Connect'

    You'll be prompted to enter the Username and Password to the share; the default username and password are stated above.

If your machine cannot resolve the Time Machine Server Name, then replace "TimeMachine" with the IP address of your WD Sharespace server; this will mount a drive to the WD_Backup folder, underwhich you will find the .sparsefile that Time Machine uses to store your backup. All this is covered in the WD Sharespace User Guide on page 46 under the Time Machine configuration section.

Note that the original poster also wrote:

However, if entering afp://wd_backup:[email protected]/WD_Backup instead of afp:// it gets to mount it from the Finder window (Command+K). I have tried this while writing this post, because as you were so sure that it worked (even though for me the "straightforward" solution does not work) I decided to try this last thing! Right now it is backing up everyting, so thank you very much for all your help!

Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .