0

I previously had Memcache running on my localhost/127.0.0.1 port 11211. Unfortunately, I rebooted my computer and now port 11211 isn't open and I don't know the command to open this port.

Can someone help with this?

0
1

you need to start memcache by typing

memcached

in terminal and leaving the window open

or start the daemon

memcached -d

you could also look for a loadctrl script if you want this to always run on boot.

5
  • -@j_mcnally, thanks that worked. Can you explain the difference -/+ the daemon -d flag? I'm not sure what a daemon is.
    – tim peterson
    Sep 27 '12 at 18:58
  • 1
    runs in background / detached from the terminal
    – j_mcnally
    Sep 27 '12 at 19:02
  • Meaning i can close the terminal window in which i typed the command and the port will stay open? It would seem like you'd want that all the time. What would be an example of a scenario where you won't use the -d flag?
    – tim peterson
    Sep 27 '12 at 19:04
  • 1
    when you want to see the output in terminal rather than logging, useful for debugging.
    – j_mcnally
    Sep 27 '12 at 19:05
  • 1
    you could alternative use something like 'screen' and detach the terminal entirely but still get the output when you reattach to it. the choice is yours. Also you could say memcached & which will background the task but still print STDOUT and STDERR to the terminal, while still allowing you to use the terminal.
    – j_mcnally
    Sep 27 '12 at 19:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .