I am running OS X Lion on a late 2008 model Macbook (not pro). From time to time, usually when left on and unattended, the battery gets low and it goes into sleep mode. I kick myself for letting it happen again, plug it in, and power back on. My session is restored as expected, but with some additional interesting graphic effects:

Cool but annoying graphics

All of the application icons when Mission Control is activated have the same green and pink striped pattern background you can see just below the menu bar, and all over the UI of Activity Monitor. This never happens after a normal sleep/wake cycle- only after the battery dies.

I haven't been able to find anybody else experiencing this, let alone somebody who has come up with a solution other than just rebooting.

I have done a few hardware upgrades to this machine- I replaced the original memory with 8GB, and I installed a 128GB OCZ SSD a few months ago. My best guess so far is that maybe it's some sort of disk cache problem, but to be honest I have no idea. So here I am.

What causes this, and how can I fix it?

  • It would help if you could publish the Console log (only for the sleep time). I suspect it is saving a sleep image using low resolution mode (due to the battery state), and when awake it brings that image, but fails to reset to normal resolution.
    – Ruskes
    Sep 18, 2013 at 10:30

3 Answers 3


I have the exact same Problem! I have a MBP 2011 model with OSX 10.75.

I have also done a few hardware upgrades to this machine: I replaced the original memory with 8GB, and I installed a second 128GB OCZ SSD disc a few months ago. The SSD is the OS disc and the original disc is now my second disk.

I have the exact problem after the deep sleep, when the machine runs out of power.

From Mark’s tip, I replaced the new 8 GB RAM back to the original 4 GB RAM, but the problem remains! I assume it is a problem of the OCZ disc. I tried to update the used firmware but I failed as I need a Windows OS to do so.

So I made a workaround: I entered in the Terminal:

$ sudo pmset -a hibernatemode 0

This means that the laptop will never enter DeepSleep (or hibernation, that is the RAM is always powered and in the event of a power loss the state is lost), and in this case the sleepimage /var/vm/sleepimage can also be removed.

Orginial Article: http://linuxtoosx.blogspot.com/2011/10/optimizing-mac-os-x-for-ssd-drives.html

It is no solution for the problem but a workaround to avoid the deep sleep. But this means that your work will not be recovered after shutdown from low battery.

  • Thanks for the workaround; I might try hooking up my old hard drive one of these days to see if I get the same behavior. My money is on the OCZ disk being the problem at this point...
    – jches
    Oct 4, 2012 at 17:16
  • I would say you lost your money... made the update to OCZ disk tools 2.22 - still the same issue :( Oct 5, 2012 at 9:29
  • it could be the disk itself, couldn't it? Or maybe a bug in the firmware that isn't fixed yet? I haven't had time to test with my old spinning-disk drive, but I will report when I do...
    – jches
    Oct 5, 2012 at 15:19
  • Yeah sure it could - but I assume you would find more reports of that bug. Or maybe we are the only guys using this SSD - What OCZ do you use? I have the OCZ Agility 3. And please give a heads up when you tested the old spinning disc drive. Oct 8, 2012 at 8:31

I have seen this a couple of times. It is memory corruption and it usually means that the graphics card is bad. Since the Graphics card and the rest of the computer are on the same board the whole motherboard needs to be replaced. Take it to the Genius Bar to get it officially diagnosed.

Apple has made this repair on two of my machines.

Since it only happens after a dead battery, it could be bad RAM chips. The Genius Bar will know for sure.


If you really want to fix it, try reinstalling OS X.

It worked for me but the problems return as soon as you run out of battery. You can try the hibernation workaround to avoid this.

  • What do you mean by "it worked for me but the problems returned as soon as you run out of battery"? Sounds like reinstalling didn't work for you at all. Are you seeing the same thing happening? Are you also using an OCZ SSD? What model of macbook do you have, and what hardware changes have you made (if any)?
    – jches
    Sep 19, 2013 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .