I have a website - www.birupakhyadash.com - which I am not able to access. The traceroute to the address returns the error: unknown host.

I have tried to clear the dns cache and disable the adblockplus browser extension, but for some reasons I am still unable to access the site.

How can I fix the "unknown host" error?


How is your system getting its DNS resolutions?

Do you have DNS servers configured in your router config or in your NIC config? If you don't and it is not pushed to your router from your ISP maybe try setting them yourself.

Use Google's DNS;


Or OpenDNS;


If you have custom DNS servers set either in your router config or your computer's NIC config, maybe those are failing. Try removing them.

Are you able to access the site from any other computer or network other than your own?

Are you accessing the website from your home network, company or school network, some other private network? Your website might be blocked!

Have you made any changes to your website's DNS record recently, which might still be propagating?

| improve this answer | |
  • Yes, my Dns Server (system pref -> network -> ethernet) already has two values. Should I change them with Google's? Is that what you are suggesting. – Birupakhya Dash Sep 26 '12 at 4:05
  • Yes, I am able to access my site from other computers, through proxy servers. – Birupakhya Dash Sep 26 '12 at 4:06
  • Here's my dns report, if that would be helpful. dnssniffer.com/en/report/www.birupakhyadash.com – Birupakhya Dash Sep 26 '12 at 4:09
  • Changing the DNS to did the job. Thanks! Weird why the previous DNS could not resolve the address now, when it was able to do so some days back. – Birupakhya Dash Sep 26 '12 at 4:19
  • I am able to access your website. Are your NIC's DNS setting auto-configed from your router or did you add them? Just for testing, try changing them to Google's or OpenDNS' IPs. Also what type of router are you using? Have you tried rebooting your router. It might help clear its cache. – thetitan Sep 26 '12 at 4:21

Sounds like your DNS server has the zone "birupakhyadash.com". Best to create a www alias to the website's IP.

| improve this answer | |
  • Can you explain a bit more about this? Including how to create an alias? – nohillside Oct 9 '12 at 3:53

Not the answer you're looking for? Browse other questions tagged .