I have a non-retina mid-2012 Macbook Pro running Snow Leopard and this issue has been plaguing me for a while.

During regular use of the laptop, while connected to my home WiFi network (to which no more than three other devices are usually connected), I keep experiencing sudden and complete drops in connectivity. It happens more than once every hour, usually while I'm browsing the Internet on Chrome and I'll see my loading tabs hang there with no response. The OS does not seem to notice this drop in connectivity, and keeps showing the WiFi icon as connected. To get the connection back I either have to wait till it returns (usually after a minute) or disconnect and reconnect the WiFi.

I think the issue is with the Macbook itself or between the Macbook and the router, because during these drops I won't even be able to connect to the router itself (by opening its web interface), and the Macbook seems to completely ignore the lack of connectivity.
The other laptop in the house (running Windows) does not experience these connectivity drops.

I have tried resetting the router, making the Macbook forget about it and then re-configuring the connection and changing WiFi modes but none of these things worked.

Here are a few more details:


Model: Linksys WAG120N;
Firmware version: V1.00.16 (most up to date);
WiFi mode: Mixed (running in G-only or N-only mode still causes issues);


15" Macbook Pro from mid-2012 (non-retina);
Processor: Intel Core i7 2.6GHz;
Software: OS X 10.8.2;

  • I have exactly the same problem, with my MacBook Air 13" mid 2012 OS X 10.8.2 (12C60) I get IP conflicts on my Belkin wireless router which 0. frequently knock other devices off the network 1. do not occur with my cerca 2008 macbook pro, acer windows box, or two android phones Renewing the DHCP lease doesn't seem to work. very frustrating.
    – user34578
    Nov 12, 2012 at 15:32
  • Did you finally get rid of this old problem through an upgrade of macOS?
    – dan
    Jul 9, 2023 at 15:15
  • Yes, this probably hasn’t been an issue for me in 10 years :)
    – kettlepot
    Jul 10, 2023 at 17:30
  • Did you know what fixed it?
    – dan
    Jul 10, 2023 at 21:19

2 Answers 2

  1. Do you have DHCP enabled? Your laptop might be loosing its connection to the router due to IP conflicts resulting from other devices on your network using the same IP address.
  2. Try using different broadcast channels. I think the default Linksys channel is 6. I usually use 8 or 1.
  3. How good is the signal strength? You might have to boost the antennas transmission signal.
  4. Make sure someone like your neighbors are not running APs with the same SSID.
  5. If you use signal encryption try using different key encryption WPA/WPA2-PSK(AES/TKIP).
  6. and the obvious one, run software updates, just to make sure that there is no new firmware for the MacBook NIC.
  • 1
    Thanks. I've tried all of the things you've listed, but I keep experiencing connection drops. It's a very annoying issue and I have no idea how I should go about discovering the cause.
    – kettlepot
    Sep 28, 2012 at 21:13

When your wifi connectivity is active , run the Wireless Diagnostics and monitor the WIFI.

Unzip the report and look at the file wifi-5gUAEy.log. 5gUAEy name is specific to that particular diagnostics report.

In the wifi-xxxxxx.log , check for the text "Will not continue auto join". If the below issue exists in your report follow the steps to fix the issue. airportdProcessSystemConfigurationEvent: Processing 'Setup:/Network/Interface/en0/AirPort' AutoJoin: AUTO-JOIN triggered (Network Service Changed) AutoJoin: user: WiFi interface is OFF, will not continue auto-join

1). Open the terminal and Go to /Library/Preferences/SystemConfiguration 2). Ensure your user has the appropriate rights to access the airport utility and network related files . 3). Provide appropriate permissions to the files and your problem will get resolved.

I had the same problem with my macbook air(OS X Mavericks & Yosemite) and tried all the resolutions given in almost all of the forums , but nothing worked.Above fix resolved my problem now, Good luck.

  • Thanks for the answer. I unfortunately do not own this router anymore (I replaced it with a high-end ASUS router), so I'm unable to troubleshoot the issue.
    – kettlepot
    Nov 15, 2014 at 17:25
  • How do I provide appropriate permission to the file ? Kind regards, Axel
    – Axel
    Dec 7, 2018 at 11:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .