I have this keyboard case for my 'new iPad' (which I had originally bought for an iPad 2): http://www.zagg.com/accessories/logitech-ipad-2-keyboard-case

(In fact, this was me: Will the Logitech Bluetooth Keyboard Case "for ipad2" work with the new ipad? )

Before I upgraded to iOS6, when I hit the "square" button on the keyboard (the same button as the single button on the front of the iPad), if the screen was off, it would bypass the lockscreen and take me straight to the homescreen (or whatever app had been running when the screen went to sleep).

After upgrading to iOS6, when I hit this button when the iPad screen is off, it dumps me at the lockscreen instead, where I have to "slide to unlock" to continue.

Is there any way to restore the previous functionality?

  • Did you change the lock settings? Or maybe they got reset by the upgrade?
    – nohillside
    Sep 24, 2012 at 13:52
  • I don't remember ever changing the lock settings one way or the other; it "just worked". I will poke around at the lock settings when I get home (don't have the ipad in front of me right now) but I wonder if anyone else is having the same specific issue and if they know how to fix it (or if we are SOL).
    – Josh
    Sep 24, 2012 at 14:01
  • ..nope, there don't seem to be any relevant locking settings that would matter.
    – Josh
    Sep 24, 2012 at 19:49
  • 1
    Oh strange.. Now I notice that if I hit any key except the square key, the ipad wakes up without lockscreen. How bizarre!
    – Josh
    Sep 25, 2012 at 0:28
  • Josh, Just upgraded a couple of days ago. I also noticed the same thing and I was quite mad. But thanks for realizing that you can wake to an unlocked screen with any key but the home key. Actually, it is a little nicer. However, I never tried with ios5 to wake the thing up with any key other than the home key, or I don't remember such a thing.
    – user30950
    Sep 29, 2012 at 0:22

1 Answer 1


I just wanted to take the opportunity to answer my own question with a (slightly overdue) update. After I upgraded to iOS 7, the behavior is actually a combination of the above. Now, hitting any key, including the square key, goes to the unlocked state.
So that's nice and corrected now...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .