2

I'm unable to enable web sharing via System Preferences > Sharing. When I click it to turn it on the light turns yellow but then goes back to gray.

I did some Googling and found that many people solved this problem by removing changes in their httpd.conf. This is my ls /etc/apache2/*.conf*:

/etc/apache2/httpd.conf
/etc/apache2/httpd_ACSServer.conf
/etc/apache2/httpd_devicemanagement.conf
/etc/apache2/httpd_podcastlibrary.conf
/etc/apache2/httpd.conf.default

I tried replacing httpd.conf with httpd.conf.default but it didn't fix the problem.

  • /var/log/apache2/error_log should contain more details on problems Apache encounters when failing to start. – Gerry Sep 24 '12 at 9:40
  • Try sudo apachectl start on the command line. See if that works. If that doesn't work sudo apachectl configtest will display the errors in your config files… – daviesgeek Nov 27 '13 at 18:53
2

Check the Apache logs with Applications > Utilities > Console. Inside Console, expand /var/log to see the Apache2 log files. You might see a message in error_log.

Without any messages, it is a wild goose chase. Here, last time Apache did not log any messages it was the port 80 being occupied by another process.

  • This worked for me, helped me to track down a failing passenger install after moving from rvm to rbenv. Totally forgot I had set that up local for apache. – JAMESSTONEco Dec 7 '13 at 20:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .