22

I have a 4 GB Micro SDHC card and I use a Micro SD adapter sleeve to read it with the built-in SD card slot of my 15" mid-2010 MacBook Pro. It's been a while since I tried to use it, but I just realized that my Mac will always treat it as read-only, no matter the position of the physical lock on the adapter sleeve.

I can't even format the partition because all the options in the "Erase" and "Partition" tabs of Disk Utility are grayed out for the SD card.

Why is the card read-only, and more importantly, how can I write to it?

7
  • I am having this problem with all of my cards, and resetting the PRAM has NOT fixed the issue. I see no solutions on any forums this issue has been posted on, but lots of people saying it eventually just disappeared by itself. I am running 10.8.2
    – user32981
    Oct 16, 2012 at 21:05
  • 2
    @Rob, I read on the Apple support forum that for a user, depending on how you inserted the SD card into the slot, it would be read-only or read-write. He said that if you put the card loose into the slot and push from the side closer to you to make contact, it becomes read-write, and otherwise it's read-only. I did it like two times without success but then the problem disappeared on third time. This looks superstitious, but at that point you might want to try anyways.
    – zneak
    Oct 16, 2012 at 21:27
  • What MBP model is this? I have a similar issue on MBP Late 2009
    – bot47
    Dec 30, 2012 at 12:44
  • It's a mid-2010, I just edited my question to include it.
    – zneak
    Dec 30, 2012 at 17:03
  • @zneak WOW your method worked for me the very first time, and this was after me trying all kinds of other ways to no avail. I have a 2011 MBP running Lion.
    – Suan
    Mar 14, 2013 at 3:10

13 Answers 13

19

In my case, a physical misalignment is causing the read only status. Gently pushing the disk away from the display reliably makes my cards write again.

1
  • Bloody hells. This saved me a lot of aggravation.
    – Jan
    May 25, 2017 at 9:14
19

Slide the read/write lock to the middle neutral position and retry. I have the same problem sometimes...

8
  • 4
    There is a neutral position on an SD card?
    – nohillside
    Nov 21, 2012 at 7:38
  • 4
    Sliding the read/write lock to the neutral position works for me.
    – user37553
    Dec 30, 2012 at 14:39
  • 4
    Weirdly enough, this worked for me (I put the switch about halfway between lock and unlock, popped it back into the slot, and all write options were no longer grayed out). Try it and post your results. Jan 1, 2013 at 3:16
  • 2
    I put the lock into the middle position as others mentioned and it, too, worked for me. How bizarre.
    – user57071
    Sep 13, 2013 at 23:18
  • 1
    This works for me too. Can't believe this will work.
    – Nevin
    Aug 27, 2014 at 4:50
3

I tried all other solutions but it didn't work.

I have a Macbook Pro Early 2011 15" (the line that has graphic card problem!)

My solution was to just push the card in as quick as I could possibly push!

1
  • 1
    This is what worked for me. And, bizarrely, the permissions for the card listed in Finder are 'You have custom access' .
    – deepwinter
    Jul 2, 2019 at 1:30
2

The problem spontaneously disappeared for me. I'm leaving this as an answer since it might reassure some people to know that for some random reasons, at some point, things start working again. However, I was not able to pin down a specific cause for it, so I'm not going to accept the answer, in case that at some point someone comes with a rational explanation.

2

@ Gordo’s answer (in toto)

Slide the read/write lock to the middle neutral position and retry. I have the same problem sometimes...

has been codified and explained. From bartech.tv's 2016 article Read-only SD cards on MacBook Pro? Here’s the solution.

The solution

The solution is, fortunately, very simple. Rather that pushing the write-protect switch all the way to the top, leave it somewhere in the middle. When you next plug the card into your MacBook Pro, you should find that you’re able to write files to, and delete files from, the card as normal.

Why does this work?

It may take a little bit of trial-and-error to get the right position, but in my case it was right around the middle, perhaps a little nearer to the top. Then, I was able to write files, and delete files as normal.

As to why this works, it’s probable that the little lever inside the MacBook Pro’s SD Card slot, which detects the position of the write protect switch, slowly degrades over time, either through continual use or a buildup of dust or fluff inside the card slot. Leaving the switch in the middle, therefore, fools the card reader into believing that it’s at the top.

It's possible/probable that the technique in @CharanBrahamandam's answer (pulling the whole card out slightly) also works because it happens to move the SD card's "switch" in the same direction as sliding the switch only from unlock to half-way in-between.

2

Since this issue involves MBP and read-only, the first idea I got is that: is this SD card formatted with the NTFS file system? As we all know that NTFS formatted drive is read-only for macOS. As the article Partition external drive greyed out in Disk Utility I've seen, it says NTFS file system is read-only on Mac computers. That's to say, you can't perform any input operation to this disk, including re-partition. So that may be the reason why the "Erase" and "Partition" tabs of Disk Utility are grayed out for your SD card.

And to check this simply check the format of this disk in Disk Utility! If it is formatted with NTFS, then bingo! that is the culprit. To write to your SD card on Mac in this situation, you can either format it with FAT32 or exFAT, or you can find some NTFS driver for Mac like Paragon NTFS for Mac, iBoysoft NTFS for Mac, Mounty for NTFS, etc. if you don't want to erase this SD card.

But if this SD card is not formatted with NTFS and it is still read-only, you need to go further to :

  • Solution 1: Format this external hard drive to exFAT/FAT32 with Windows PC
  • Solution 2: Run NTFS for Mac software on Mac
  • Solution 3: Fix read-only NTFS external hard drives with the command line
  • Solution 4: Change the permission of this external hard drive
  • Solution 5: Ignore Permissions on the external hard drive in the Finder
  • Solution 6: Repair read-only external hard drive with Disk Utility

Reference from :How to solve external hard drive read-only without formatting on Mac?

2
  • Question stated that read-only status means formatting can't be done.
    – WGroleau
    Nov 4, 2019 at 15:56
  • Yes, and mentioned before, if the disk is read-only because of NTFS, using NTFS driver for Mac or reformatting it to a Mac-compatible file system in Windows would be a feasible solution. Nov 5, 2019 at 2:48
1

Is this problem for all your SD cards or just one. If just one, I would try formatting it in FAT from a PC and then trying that.

I had a USB flash drive that I had installed a Linux distro on and it gave me similar issues on my Mac mini.

2
  • Well I have two Micro SDs at hand and both exhibit the same behavior. I formatted the 4GB one to FAT32 from my digital camera (since that's what I wanted to do anyways) and I still can't write to it.
    – zneak
    Sep 23, 2012 at 21:57
  • Also, Linux distributions are generally installed on an EXT filesystem, so my feeling is that you just couldn't write to the filesystem, instead of to the device itself. In my case I can't write to the device at all, and a format didn't fix it.
    – zneak
    Sep 23, 2012 at 22:09
1

According to one user on the apple discussion forum, resetting the PRAM should fix the issue:

From Apple KB

  1. Shut down the computer.
  2. Locate the following keys on the keyboard: +Option+P+R. You will need to hold these keys down simultaneously in step 4.
  3. Turn on the computer.
  4. Immediately press and hold the +Option+P+R. You must press this key combination before the gray screen appears. Continue holding the keys down until the computer restarts, and you hear the startup sound for the second time.
  5. Release the keys.

Note: Resetting PRAM may change some system settings and preferences. Use System Preferences to restore your settings.

3
  • I'll try that when I get back home.
    – zneak
    Sep 26, 2012 at 21:50
  • 1
    The problem spontaneously disappeared today, so I'm afraid I can't verify anything. Still, thanks for the tip, if this happens again I'll try that.
    – zneak
    Sep 27, 2012 at 14:31
  • Surprisingly, this help!
    – Bing Han
    May 4, 2018 at 15:31
1

The tricks above worked for me but less and less so. It feels like a hit and miss and can easily take me 10 tries.

This annoying problem has another potential fix. When I need to get my card into Read/write mode I can do this by taping over the slot of my card where the lock slide is. It does not matter where the lock slide is set to as it will be masked by the tape anyway. This works 100% of the cases. It does have disadvantages:

  • potentially getting tape stuck into the reader (be careful)
  • need to apply it and take it off each time tape
  • might take the paper of any label sticker on the SD card off

I’m actually going to buy a reader because of these disadvantages.

1
  • 1
    I also ended using an external card reader. Jan 22, 2017 at 23:20
0

Another thing to ensure when trying all these 'tricks' is to plug the laptop into a power supply. Because the card reader draws power if the battery is not delivering enough current to the reader it can cause issues. For example, mounting of problematic USB hard disks can be resolved by plugging the laptop to the power supply.

1
  • This sounds more like superstition than like an actual explanation. A card reader acting on NAND Flash storage needs much, much less power than an actual hard drive. My laptop was connected at all times when I had this problem.
    – zneak
    Jul 13, 2014 at 16:24
0

I regularly have this problems with my macs ...so I bought two card readers. One is an Advent one... but that wont let me write sometimes either. The one I have by Puremedia seems to have no problems though .. so I stick with that.

0

Just simply format the card in fat32 format and the reformat it to ntfs that will fix the problem it worked for me XD

1
  • FAT is not journaled hence unsafe, Moreover, SDXC cards only work with exFAT. Nov 6, 2020 at 21:45
-1

Open Disk Utility, find and select the SD card, then click Repair Disk from the First Aid tab. You should now be able to read and write.

Disk Utility Repair Disk

2
  • Didn't work for me when I had this problem.
    – zneak
    Sep 7, 2013 at 16:43
  • Wouldn't the volume be greyed out if it were mounted read-only? I suppose you should be able to unmount it and then attempt a repair, but my guess is the item you have listed as 8.02 GB Apple SDXC Rea… would be grey in the case of this question.
    – bmike
    Sep 7, 2013 at 17:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .