5

I would like to clean up the massive amount of junk in my contextual menu. I have VM Fusion 5 installed and it is one of the main culprits, showing multiple entries of Windows Apps within my context menu of the Mac OX.

Example of 'junk' in my context menu for a txt file = Notepad listed 5 times, Textpad listed # times, Visual Studio listed 6-7 times, and more .

I found an article explaining what to do for a previous version of Fusion, Remove VMware Fusion and Parallels "Open With" Context Menus. I have searched and I cannot see what resembles the previous option "Open your Mac files and web links using Windows applications".

If anyone can help I would appreciate it.

The following line in the terminal worked:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

I just don't want items returning because of Fusion.

Thank you.

4
  • If I understand you right you managed to remove the "junk". So what exactly is the question here?
    – nohillside
    Commented Oct 7, 2012 at 15:53
  • 1
    This is what I call junk. s14.postimg.org/9j22sb4f5/…
    – diek
    Commented Nov 19, 2013 at 21:47
  • @mikemaccana edit makes perfect sense.
    – diek
    Commented Oct 23, 2015 at 14:58
  • If you've already uninstalled Fusion (yaay Veertu!): @diek's command above is all you need. Commented Feb 12, 2016 at 16:08

2 Answers 2

5
  • Inside Fusion, open the Virtual Machine Library window – Window menu > Virtual Machine Library, or press CMD+SHIFT+L.
  • Select the VM and click the Settings button.
  • Click the Applications icon, and then select the Default Applications tab.
  • Uncheck Open your Mac files and web links using Windows applications and close the window.

Repeat the process for every VM.

3
  • 1
    How does this differ from @root's answer?
    – mmmmmm
    Commented Mar 21, 2013 at 14:14
  • The first answer doesn't make it clear that this setting is independent for every VM in your VM library. You may infer that from the instructions as described ("go to Virtual machine->_Settings_). However, since that is the correct fix and is said to have not worked, it is a reasonable assumption that the user missed that point, and only changed the setting on one VM. "TL;DR" version: the last line is the difference: Do that for every VM
    – Tim B
    Commented Mar 21, 2013 at 15:21
  • 1
    If you don't want to reboot after doing this run the following command in terminal: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user then killall Finder Commented Nov 15, 2016 at 22:45
5

In VMWare Fusion:

  • go to Virtual Machine->Settings,
  • select Default Applications,
  • Uncheck Open your Mac files and web links using Windows applications
  • Repeat this for all virtual machines
  • Reboot your Mac

Now the Open With options for apps in your virtual machines should be gone. Personally as I don't like my VMs to creep into the guest OS I keep all checkboxes here unchecked.

5
  • Hi,That option is not displayed in VM Fusion 5, there are 2 items under default apps: 1. Open Mail, and 2. Open Web Pages.
    – diek
    Commented Sep 24, 2012 at 23:44
  • Just tried it again, and got the option. I will try that. I was obviously going in the wrong route to get that option.
    – diek
    Commented Sep 24, 2012 at 23:56
  • I need a few days to check this out, I am swamped at school and I some time is needed for testing. The last time I rushed accepting and answer it turned out to be wrong. I do appreciate the help.
    – diek
    Commented Sep 25, 2012 at 23:14
  • So the problem returned. A full bloated context menu.
    – diek
    Commented Oct 11, 2012 at 3:43
  • And how to remove context menu items for removed virtual machines???
    – Dmitry
    Commented Aug 30, 2013 at 17:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .