I have been using AirPlay to stream stuff to my Apple TV for months, and it's been great. In the last week or so it stopped working for 3rd-party apps.

  • I use Radium on my Mac. This used to work fine but now when I unmute Apple TV it mutes itself again as soon as it starts to play.
  • I use the Digitally Imported app on my iPhone. I used to be able to stream this to Apple TV but now when I choose it it stops playing.

In both cases Apple TV shows up as a potential output device, and disappears and reappears as it should when I switch AirPlay off and on again on my Apple TV. I've tried 2 different routers and both wired and wireless connections. There is nothing relevant in the Console logs on my Mac that I can see.

The odd thing is that iTunes on my Mac can still play to it, and AirPlay mirroring works fine too, so it does seem to only affect 3rd-party applications.

How do I fix this?

  • To tell you the truth, I am having the same issue. I am not sure if it came with the last Mountain Lion update. It was working the other day. listening to music on Saturday 22/09/12. Then video on TV and music on the mac. Selected audio settings . did so on advice of a website. every time i select my AppleTV it keeps bouncing off - unselectable. upgraded the Apple Tv but that did not help.
    – Darren
    Sep 26, 2012 at 20:43
  • Thanks. Strangely enough that is all I had. It just stopped working. So I restarted the laptop in a Windows fixing sort of style and lo and behold, the Airplay is back and allowing audio to the TV. Fixed.
    – Darren
    Sep 28, 2012 at 6:49
  • Restarting everything didn't help me.
    – GraemeF
    Oct 6, 2012 at 10:07

1 Answer 1


The recent 5.1 software update to Apple TV seems to have fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .