I recently clean installed Mountain Lion to my mid 2011 iMac, and ran into a frustrating issue when joining my Wi-Fi network. All my other Apple devices have no trouble accessing the same wifi, except this very iMac. The typical error message is either "See network administrator" or "Connection time out"

I did try to update the iMac to the latest (10.8.2 at the time of writing), and I still can't join the WiFi.

On the same iMac, if I reboot and boot into ubuntu Live CD, I was able to join the WiFi using the same internal wireless card. It leads me to think that something is off with Mountain Lion.

The router currently uses WPA2. I also did a wifi analysis and picked a channel that is least used by nearby routers.

I also spent quite sometime doing research. I cleaned up the Keychain-access, and I removed and re-added the network within the Wi-Fi network settings. I also make sure that SSID of my router has no "-" or any other weird characters. I also reset my router a few times, but it didn't help

The iMac came with Lion, and the WiFi connection to the same router wasn't all the stable, but at least I was able to connect. With Mountain Lion, nada no dice, not even connecting once

I am running out of ideas, and the current workaround is to rely on wired cable directly to the router. Or if I really want a stable wifi on this iMac, ubuntu. Any suggestions are greatly appreciated.

2 Answers 2


I faced a similar issue on my MacBook Pro with one particular WIFI connection. It was giving me the "Connection time out" error message.

I was able to workaround it by:

1) Removing the WIFI connection: System Preferences > Network > WIFI > Advanced > Select the relevant connection and click the "-" sign > Click "Show All" or close the window.

2) Adding the connection manually: System Preferences > Network > WIFI > Advanced > Click on the "+" sign > Enter the connection settings manually.

This has worked for me and that particular connection never gave me issues afterwards.

Hope this helps.

  • Melwan, thanks for the tip. That's actually one of the first things I tried. I went even further by cleaning out all the cached passwords for my network under the Keychain-access. Still no dice.
    – Antony
    Commented Sep 23, 2012 at 13:26
  • Have you tried changing the channel of the connection from within the router settings? Channel 11 seems to act up for my setup. I usually set it up for Channel 6 or 1.
    – Melwan
    Commented Sep 23, 2012 at 15:09
  • Yep, based on the wifi survey (InSSIDer on a separate working Windows box), I have switched to a least used channel. both 1 and 11 are fairly occupied, so I have chosen 6. Still no go.
    – Antony
    Commented Sep 23, 2012 at 17:50
  • 1
    Does your working account have administrator privileges? If it doesn't, log in as an admin and set up the wifi connection. Commented Dec 9, 2012 at 21:14

So it turns out the issue has to do with the incompatible router itself zyxel nbg-416n with the latest firmware appears to reject the iMac somehow.

When I switched to another router d-link running openwrt, iMac connects just fine. So the solution was to switch router

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .