I'm having an intermittent problem in which my Macbook Pro has been working fine for several days and many sleep/wake cycles but then it has a problem waking up from sleep. The disk spins up and the computer seems to be running, but the screen backlight doesn't light up and the computer is unresponsive.

I've tried closing it for a while and opening it again; pressing option-cmd-esc; pressing the start button one or more times; pressing other keys randomly. None of these resolves the problem. The only response I get is that sometimes pressing keys gives the "ping" error sound that the Mac produces when you hit an inappropriate key when a dialog box is open.

My rough guess is that this has been happening about once a week or so, but I haven't been keeping close enough track to figure out if I've been doing something similar just before each time this problem occurs.

Holding the start button down turns the computer off and then I can restart and the computer works fine again. But I sometimes lose the unsaved portion of my work and reopening all the files I was working with can be time consuming. All in all, it would be nice to find a better solution than a forced restart.

Does anyone have any ideas about what might be causing this? Is there a way to recover without having to do a forced shut-down and restart?

My computer is an Early 2011 Macbook Pro Core i5, 8GB RAM running Snow Leopard.

  • Is there anything interesting in the logs or Console.app? Have you installed any kernel extensions? Have you tried resetting the SMC or NVRAM and PRAM?
    – Lri
    Sep 23, 2012 at 15:05
  • Try sleeping the computer from the Apple menu instead of shutting the lid. If the display turns on consistently when you wake it that way, then most likely the cable connecting the display is loose.
    – daGUY
    Jan 31, 2013 at 17:36
  • Does this help? apple.stackexchange.com/a/12330/202413 Jan 28, 2018 at 22:34

2 Answers 2


You may want to rule out a graphics card issue, which impacted select 2011-2013 MBPs:


And if you haven't done so already, run Apple Hardware Diagnostics:



i have the exact same problem, i think the only solution is a reinstall.

  • Reinstalling is a solution. This is, technically, an answer.
    – Daniel
    Nov 6, 2013 at 4:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .