After upgrading to Mountain Lion on my MacBook Pro, I noticed an update was available for iPhoto '11 (version 9.4) I went to App Store -> Updates and it downloaded and than hung. The message I received was

iPhoto failed to download - Use the Purchases page to try again

I tried going through Purchases and get the same message. I'm caught in the "loop" and don't know how to get out. Now there's a red letter message beside the UPDATE button that says "An error has occurred"...

How can I download this upgrade?

  • I have the same problem with an update of Xcode, though it has already been installed.
    – duci9y
    Sep 22, 2012 at 18:20

5 Answers 5


I had the same problem with a bunch of Apple apps. I restarted my computer a few times and they eventually went through. It has to be an issue on Apple's end because I had the issue on a brand new retina MacBook Pro with 10.8.2, and I don't muck around with any system stuff.


I had the same trouble with downloading iPhoto 9.4.1 on my iMac running Mountain Lion.

I kept getting download error and the red badge would not go away. I finally got the download to work by holding down the 'option' key and pressing the update button.


I posted a long answer to my root cause on this problem in another question. I had a mirrored root drive with "old" versions of the apps on the mirror. Inexplicably, App Store was in a sense monitoring the Apps folder on there and became confused. Read it here Xcode failed to download. Use the Purchases page to try again


I have tried almost everything it has been said on the internet to solve this annoying problem. None of them worked. Even Apple Support could not find a solution. But yesterday I have found the solution with the help of my luck.

After download starts in App Store but before you see any error, before you see any turn back in download progress, click on the red button in the corner of the window and close App Store.

Do not worry... You will not get any error message this time. Instead, you will see on Launchpad icon that it is still being downloaded. Just wait... Download will finish eventually and you will find its icon on Launchpad.


Make sure your Mac OS is up to date. I was having these issues updating XCode and tried many of the solutions on SO, however, it took updating the operating system to fix the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .