Bought my father a 64GB Macbook Air as an upgrade to his old Macbook, and thought it was wise to move his ~60GB photo collection (heavens knows why it is so big, bigger than my own collection on Flickr!) to the time capsule.

Didn't realise iPhoto on Mountain Lion would need to upgrade it making it impossible for the old Macbook to access it.

Iphoto Library is locked, on a locked disk, or you do not have permission to make changes to it.

After the long upgrade it seemed to worked. Then all of a sudden the "iPhoto library is locked". The user has write access to the "Data" Volume of the Time Capsule (series 1). There are many suggestions to run iPhoto holding down option+cmd to repair, but it doesn't work. It just goes to the "Caution" dialog and quits.

I am a Archlinux user, so I'm very comfortable on the command line.

  • The iPhoto library being locked probably means that iPhoto was forcefully quit while modifying the library. See if there is any hidden file with a lock in its name. – duci9y Sep 22 '12 at 18:24
  • static.dabase.com/iphoto-info.txt has lockfile.pid and iPhotoLock.data. Feel like I'm stabbing in the dark here... suck – hendry Sep 22 '12 at 18:35
  • Delete or rename those files and see if iPhoto works. – duci9y Sep 23 '12 at 6:49
  • Did you try to double click on the library itself? – user64019 Dec 4 '13 at 9:13

i had a similar problem opening an iPhoto Library backedup by Time Machine prior to reformatting HD and reinstalling OSX Snow Leopard.

in some cases (like mine), no amount of permission repairing or resetting will solve the problem. apparently, because i reinstalled OSX from scratch (reformatting disk first), the Time Machine backup belongs to a defunct user. therefore, even though the username and password are the same, the file that i extract DIRECTLY from TM will be always read-only (i could go via terminal and try some chmod'ifications, but...). therefore, the issue must be tackled with a different approach:

  1. open iPhoto
  2. open FILE menu tab
  3. choose FIND BACKUPS (translated from Portuguese)
  4. select your timeMachine backup and find the specific image/date you want
  5. browse to the iPhoto library you want to import (there may be various - i had 2)
  6. create a new folder in Documents (where permissions will not be an issue)
  7. after iPhoto backup has been restored to this folder, go to FILE > IMPORT

voila. worked for me, i hope that this helps the many others who run into the same problem after reformatting and reinstalling OSX leopard (regular or sLow, both seem to act up).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .