I'd updated my Macbook to Mountain Lion, everything works fine. In fact, iPod Touch 4th generation is also visible in iTunes but iPod touch 3rd generation is not appearing in iTunes. Please find below use case:

When I connect iPod touch (3rd gen)

a) It starts charging, and the Apple logo appears, but is not visible in iTunes in Mountain Lion.
b) It starts charging, and the Apple logo appears, but is visible in iTunes in Snow Leopard.

  • Same thing happened with iPhon5, I bought iPhone 5 today and tried to sync with ML's iTunes but failed. Any suggestions.I think "there is some issue in ML USB drivers" . It was working fine in case of SL. – ManjotSingh Nov 24 '12 at 14:13
  • Does WiFi syncing work? That might alert you to where the problem lies? support.apple.com/kb/HT1386 – bmike Nov 26 '12 at 20:09
  • @bmike Actually, I tried this but issue is same. Let me explain you usecase what is happeneing - When I connect iPhone5 or iPod touch with my Macbook(ML) it appears in iPhoto but not in iTunes, I found one more thread and followed but not benefitted. Please suggest. – ManjotSingh Nov 28 '12 at 12:10
  • Please go thought the article, step by step. It points to this article support.apple.com/kb/TS4062 if you need to troubleshoot why the device does not show. – bmike Nov 28 '12 at 14:44
  • I followed the article. I found issue is with Macbook not with iPhone because device is appearing other Mac Mini. I called up in support not found relevant solution. Issue is with Macbook either I need to reinstall the ML or you can suggest also. – ManjotSingh Nov 29 '12 at 7:51

You must log in to answer this question.

Browse other questions tagged .