I have a Cisco wireless router WAG54G2 Annex A plus Cisco Extender RE1000. The router is upstairs and extender helps me strengthen the signal downstairs and have been having issues keeping a wireless connection going using my MacBook Pro with OSX Mountain Lion (10.8.2 since latest upgrade) for weeks now. Issues keeping connected to the local network and or to the internet. The phone company, also our ISP, has passed by and told us the telephone line is fine so that is not the issues. So is must be a routing issue locally and perhaps as well an issue with the ISP's router kicking us out. I am talking our local Thai ISP TOT. Here is part of the log on the issues getting connected. I am posting this using my iPhone's 3G connection and regular network connection when I can...

NB Someone with a similar issue opened a thread here Macbook Pro frequently experiences drops in WiFi connection with Linksys WAG120N

9/21/12 9:28:55.000 PM kernel[0]: en1: TKIP countermeasures enabled.
9/21/12 9:28:55.000 PM kernel[0]: en1: Group TKIP MIC failure reported!
9/21/12 9:29:05.000 PM kernel[0]: wlEvent: en1 en1 Link DOWN virtIf = 0
9/21/12 9:29:05.000 PM kernel[0]: wl0: Beacon Loss Event
9/21/12 9:29:05.000 PM kernel[0]: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).

Reason four. What is this reason? Just because my MBP does not communicate well enough with the router? Is there a way to make them communicate better?

9/21/12 9:29:33.896 PM sandboxd[4536]: ([4535]) mdworker(4535) deny mach-lookup com.apple.ls.boxd

Reading on this here: https://stackoverflow.com/questions/10820884/what-does-this-sandboxing-message-deny-mach-lookup-mean

9/21/12 9:29:34.000 PM kernel[0]: Sandbox: sandboxd(4536) deny mach-lookup com.apple.coresymbolicationd
9/21/12 9:29:56.000 PM kernel[0]: MacAuthEvent en1   Auth result for: 58:6d:8f:6a:d5:9a  MAC AUTH succeeded
9/21/12 9:29:56.000 PM kernel[0]: wlEvent: en1 en1 Link UP virtIf = 0
9/21/12 9:29:56.000 PM kernel[0]: AirPort: Link Up on en1
9/21/12 9:29:56.000 PM kernel[0]: en1: BSSID changed to 58:6d:8f:6a:d5:9a
9/21/12 9:29:56.000 PM kernel[0]: en1::IO80211Interface::postMessage bssid changed
9/21/12 9:29:56.000 PM kernel[0]: wl0: Roamed or switched channel, reason #4, bssid 58:6d:8f:6a:d5:9a

Here another reason #4, but on the bssid. No idea what this means yet..

I tried resetting the main Cisco Router, the extender and or both and reconnecting, but for the last hour or so I have been unable to reconnect.

Also get this error a lot:

9/21/12 9:34:31.000 PM kernel[0]: MacAuthEvent en1   Auth result for: 58:6d:8f:6a:d5:9a Auth request tx failed

Does anybody has any ideas how to trouble shoot this further so I can keep my connection going longer then an hour or two? Is there perhaps a ML issue or issue between Mountain Lion and my particular Cisco router?


When all is running:

ifconfig en1
    ether 00:26:bb:05:00:5b 
    inet6 fe80::226:bbff:fe05:5b%en1 prefixlen 64 scopeid 0x5 
    inet netmask 0xffffff00 broadcast
    media: autoselect
    status: active


Did some more testing. It seems that when I reset the main router and extender consequently I need to wait a bit before I reconnect with my Mac. That why they can both hook up and the MBP gets connected properly as well. So the initial commentator @duci9y was right on that. The reason why the main router gets kicked of the network very often is another issue. I'd say an ISP issue. Looking into ways to troubleshoot this now.

Update II

Got kicked of the network (wifi) again and saw this:

9/22/12 10:24:56.000 AM kernel[0]: wlEvent: en1 en1 Link DOWN virtIf = 0
9/22/12 10:24:56.000 AM kernel[0]: wl0: Beacon Loss Event
9/22/12 10:24:56.000 AM kernel[0]: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).

So somehow I lose the connection due to inactivity? But I am online and doing stuff??

Update III

Deleted all known networks - read in an Apple thread that this could help and I go reconnected again

Update IV

I am using

ping route get default | awk '(/gateway/){print $2}'

to keep the connection allive. Found the suggestion here at the Apple forums.

Update V

Still lost my internet connection. Wifi did survive. I could no longer ping the main router. So perhaps this is again connected to the extender not being able to stay connected to the main router. After I briefly turned off wifi on my MBP and on again I got reconnected.

Update VI

Doing some tests without the extender now. Just to see that was the culprit for real.

Update VII

Was having an OK wifi connection for about an hour without the extender and then got briefly disconnected due to "inactivity" again:

9/22/12 12:44:36.000 PM kernel[0]: wlEvent: en1 en1 Link DOWN virtIf = 0
9/22/12 12:44:36.000 PM kernel[0]: wl0: Beacon Loss Event
9/22/12 12:44:36.000 PM kernel[0]: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).

Very odd as I was downloading stuff using uTorrent. Seems like the main router can no longer be found for a while. After a couple of minutes I get reconnected again most of the time, but it is really annoying. Makes me think it is not the extender, but the router kicking me and or the extender out every now and then..

Update VIII

Updated router to Firmware Version:V1.00.19 . Let's see if this improves the connectivity

Update IX

All seems to be doing better. Did have one issue getting kicked out this morning, but will keep on observing for now. Other input is always welcome!

Update X

Had several cut-offs this morning with and without Extender:

Sep 25 10:11:48 jaspersmbp kernel[0]: wlEvent: en1 en1 Link DOWN virtIf = 0
Sep 25 10:11:48 jaspersmbp kernel[0]: wl0: Beacon Loss Event
Sep 25 10:11:48 jaspersmbp kernel[0]: AirPort: Link Down on en1. Reason 4 (Disassociated due to inactivity).
Sep 25 10:11:48 jaspersmbp kernel[0]: en1: BSSID changed to 00:00:00:00:00:00
Sep 25 10:11:48 jaspersmbp kernel[0]: en1::IO80211Interface::postMessage bssid changed
Sep 25 10:11:49 jaspersmbp configd[16]: network changed: v4(en1-: DNS- Proxy- SMB

Maybe I should use a Windows system and or change my main router..

  • 1
    Sounds like an error in the handoff between your router and extender. Do other devices work well or are they affected too?
    – duci9y
    Sep 21, 2012 at 15:16
  • Seems to be mainly an issue with my MBP, not with my iPhone or other iPhones or devices at home. Could be an extender issue. Perhaps when the internet dies for a bit the extender does not pick the newly created connection and when wifi goes down it is even worse. Must say I am starting to long for an old fashioned ethernet cable again..
    – rhand
    Sep 21, 2012 at 15:26
  • I've removed the automatic wiki flag since you have edited this question so many times. Please try to either ask a "how do I troubleshoot" that could be answered with some reasonable back/forth comments and perhaps a followup - question to document what the root cause was and a brief summary of how you got to the answer. It's OK to ask and answer a question as long as the question stays in the question. (and all the answer ends in the answer - here you have a lot of answer in the question)
    – bmike
    Jan 4, 2013 at 1:57
  • May I know how do you generate those logs? I'm having the same wireless connectivity problem with my 2012 MBP (Mountain Lion) but with a different router.
    – hsym
    Aug 24, 2013 at 1:33
  • For Mac you can use the console to check any logs you want. Use finder to find console or go to Applications > utilities > Console
    – rhand
    Aug 24, 2013 at 5:15

2 Answers 2


The beacon loss event is the key. Your wireless card lost contact with the router and gave up.

wl0: Beacon Loss Event

If you can, change your beaconing rate on the router to be faster (and slower - sometimes the opposite of the intuitive thing is the answer). Also you should run the Wi-Fi Diagnostics tool which resides in /System/Library/CoreServices and monitor the performance of your setup. This will let you see the signal and noise so you can pick a channel on the router that loses the beacon the least often. There is a lot of data here, but the most important number is the txRate. It is how well your radio can talk to the router radio. All other measures end up reflected here. If you have bad signal, or bad noise, this goes down. The higher you can get the transmit speed, the less likely you will lose the beacon.

It could be just that the Mac hardware doesn't like the beacon pattern of that router and in the end you pick up an Apple router (or another one) - but you should be able to try some more things and perhaps make this better.

Ignore the sandboxing errors - sandboxing would prevent all operation, all the time and not lead to an intermittent failure.

  • My Beacon interval is 100 msec which is standard. I made it fifty for now. Also ran a Wi-Fi Diagnostics report. Many files were generated.In link-info.log I found txRate = 36; in each sample - see pastebin.com/Y6QgAA22 . Will see if the beacon interval change will help. Was considering an Aiport Extreme or Time Machine ..
    – rhand
    Sep 29, 2012 at 2:13
  • having the same issue with my new MBP running 10.8.2 - the above solution is intriguing (seen others suggesting reducing MTU size from 1500), but could you please explain: - will increasing beaconing rate decrease battery life (or other adverse effects?) - where can i find the log file cited above (am a mac newbie)? thx!
    – Nikita
    Nov 3, 2012 at 19:40
  • @nikita - the difference on power draw between faster or slower beaconing rate would be totally negligible. The airport card just receives and reacts to beacons. Please ask a new question linking here (copy the link from the share button) and I'll get you an answer how to use console.
    – bmike
    Nov 3, 2012 at 20:37
  • 1
    Just FYI: As of Yosemite, Wi-Fi Diagnostics is now /System/Library/CoreServices/Applications/Wireless Diagnostics
    – sherb
    Nov 3, 2014 at 19:04

I'm not sure this thread is still active or not but thought I'd put in my experience and research as this came up on a search for solutions. I'm not a power user and yet I'd like a shot at answering this question. The answer I have is: "Nothing can be done." I have had a Cisco Valet M10 - not a power router but all I need - which has worked wonderfully to link my MacBook Pro (late 2011), printer (HP Deskjet Wireless 8500 All-in-one) and a small, mini HP (Windows 7) until I upgraded to Mountain Lion. It also works great with my iPhone 4S running v. 6.2. I just chatted with Linksys and was told that their technicians are working on upgrading to Mountain Lion but had no product at present that works with that OS. Well, here's what happens to me. First, it bumps my printer off-line and I cannot get it to connect. I go to the printer and reconnect to the router then just as soon as I try to print, the printer goes off-line. I don't use the little mini PC so don't worry about it. On my computer itself I keep being bumped off as well. I go up to the wireless icon at the top toolbar and when I left-click on it, it says it's searching for a network. I click on mine and it says it's on and I can work on-line for awhile before it kicks me off again. It's usually when I try to go to a new tab or website. Eventually, Safari just gives up and freezes. I'm not sure Apple gave out to peripheral vendors the specs nor gave them enough time to adjust, but that is simply my opinion. That statement however, I feel is justified because there are so many programs and apps that I use that do not have an upgrade to work with Mountain Lion. I, too, wonder if I should go back to a Windows-based computer. But I've spent way too much money on changing to a Mac in terms of programs for Macs, etc. Think I will try my little mini PC and see what happens there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .