I've been having a problem with installing and updating apps after upgrading to iOS 6 on my iPad (3rd gen). When I click the Install or Update button the button, it turns inactive with "Installing" word on it, while the app's icon on the SpringBoard says "Waiting".

I tried even buying a new app, but it is exactly the same. Deleting the app and trying again doesn't help. What's interesting the problem doesn't seem to affect my iPhone 4S.

I noticed several people at Apple Support Communities are affected by this, too.

  • I declined the flag to make this CW. the downside of denying rep seems to outweigh any benefit CW would offer here. Feel free to ask again on Ask Different Meta and we can review if this is the best choice for CW.
    – bmike
    Nov 3, 2012 at 11:13

4 Answers 4


I've been fighting with this for several days now, and I think I finally cracked it. Check your iTunes Downloads (iTunes->More->Downloads) in iOS for stuck downloads. I had a music video that appears to have been gumming up the works.

Here's the official Apple KB article covering this:

Prior to pausing that download I had tried rebooting, logging out of iTunes and all the other suggestions on lots of other blogs/sites/forums.

  • Jeremy you legend! All it was was a huge iTunes d/l... The free Sherlock episode from 12 days of xmas. Caused me a lot of heartache for the last day!
    – user37475
    Dec 28, 2012 at 23:21
  • SO Glad I could help. It was driving me crazy before I found the solution.
    – jeremy
    Jan 2, 2013 at 15:53

I had the same problem and after none of the other suggestions worked (changing date/time, shutting down and restarting), I went to Settings > iTunes & App Stores, then clicked on Apple ID > Sign Out. After signing back in, I was able to start downloading apps again.


There are a couple of things that you can try to resolve this issue:

  • delete the stuck apps, sign out of the App Store, sign in back again and try installing again
  • delete the stuck apps, turn on Airplane Mode for about 30 secs, turn it off and try installing the apps again
  • stop or delete any remaining iTunes downloads. This worked for me. I've been downloading quite a few songs from my iTunes in the Cloud and some of them got stuck. It was not until I deleted the stuck and remaining iTunes download that app downloads would resume.

Before you deleting apps just try powering off the phone and then on again - worked for me - so glad I didn't delete the 17 apps that were stuck and then have to go and find them all again!

  • 1
    This is a very good minimal solution, I've also had luck placing the device into AirPlane mode and then going through the normal shutdown / restart process. By getting to a good network (WiFi with good bandwidth) helps let this process complete by itself. iOS 5 had single threaded downloads / installations of apps, and iOS 6 enables many at one time and may expose some networks that are simply not capable of handling that many simultaneous downloads in a reasonable amount of time. Too many active tasks would ensure none complete.
    – bmike
    Sep 26, 2012 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .