3

I just got a new iMac, and installed iTerm (0.10). On my last laptop 256 color mode worked fine, but I'm having trouble getting this to work on my new Mac.

I copied over all the settings, set $TERM to xterm-256color, but no dice.

I changed my .vimrc to the absolute minimum to try this out:

set t_Co=256
syntax on

Tried multiple colorschemes, too.

5
  • This SO question suggests using let t_Co=256, not set. Any results? stackoverflow.com/questions/3761770/… Jan 16, 2011 at 19:43
  • Also might try this article: jimlund.org/blog/?p=130 Jan 16, 2011 at 19:45
  • iTerm2 has the advantage of developer support for these kinds of issues. sites.google.com/site/iterm2home
    – user2551
    Jan 17, 2011 at 20:53
  • I just installed iTerm2 this afternoon, and it's excellent, Much closer to Terminal.app in it's cleanness, but with the extra functionality of iTerm, plus a few extra features of it's own. GLTerminal is also a lot of fun, but thin on extra features ;)
    – ocodo
    Jan 29, 2011 at 8:13
  • FYI, in Lion, Terminal supports 256 colors and has a number of other enhancements. It may be worth taking a look to see whether iTerm2 still offers something you specifically want that Terminal doesn't.
    – Chris Page
    Aug 11, 2011 at 5:36

1 Answer 1

1

OK, so...

I just started vim again, and colors where there. Since then I did make a changehowever, I installed XCode. This is the only thing I did change, so there must be something in there that fixes this.

Thanks for the effort!

1
  • Prior to Mac OS X Lion 10.7, the terminfo files for xterm-256color and some others were part of the Xcode install instead of the regular system install. In Lion, they are now part of the system install.
    – Chris Page
    Aug 10, 2011 at 1:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .