My wife's iPad, which has been working perfectly since she bought it almost a year ago, has, as of a few moments ago, stopped connecting to our home WiFi network. My laptop (2010 MBA) and her laptop (2012 MBA), both iPhones (4s) and my iPad (New iPad WiFi) and my brother's laptop (2011 MBP) all connect to our WiFi perfectly.

However, when her iPad tries to connect it will work but then the "login" page that happens at, say, Starbucks, will come up (the Hotspot Assistant or whatever it's called) and shows a "Page not found" error. Then the WiFi disconnects.

It was working fine earlier, now after upgrading to iOS 6 the problem has come up.

Is it a bug that's affecting a lot of users or is it something that's been around for a while and just never happened to her?

  • 1
    Yeah, I've got this problem too. And after a bit of a search on the net this problem seems to be popping up for others too. Just got it working now after forgetting the network and reentering details but not sure if it was just co-incidence or not. Sep 19, 2012 at 23:36
  • Hey man, goto settings - safari - clear cookies and data and then restart. I just tried that and it worked. Spread the word!
    – Zrb0529
    Sep 19, 2012 at 23:43
  • I would try, like Mike said, forgetting the network, and reentering the password. After that, I would go to Network > General > Reset > Reset Network Settings. IF, in the event that does NOT work, I might even consider doing a restore - if you have an iCloud backup, this can be done very easily. Sep 19, 2012 at 23:43
  • Same problem here with my ipad2. Will try all the recommendations in the previous posts. Worked fine till the new ios6 update 2 hrs ago. Thanks for the tips!
    – user30369
    Sep 20, 2012 at 0:47

2 Answers 2


The solution is to clear your Safari cookies and settings:

Settings - Safari - Clear Cookies and Data - Restart

  • Another potential source for this is network settings. You could clear them assuming you know the passwords to join the Wi-Fi.
    – bmike
    Sep 20, 2012 at 0:49

Go into settings - Cellular Data - APN settings. This would have been reset after the update. Amend to suit your particular carrier eg Optus - key in - yesbusiness - all one word and in lower case. Restart and all good!

  • APN settings are for cellular, the iPad mentioned in the question is a WiFi only model having problems connecting to a WiFi network.
    – nohillside
    Oct 13, 2012 at 14:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .