My Downloads folder in my dock has been showing a download/progress bar at 50% since yesterday. There aren't any half-complete files in my Download folder, Google Chrome isn't awaiting any action to accept or discard an upcoming download nor am I copying anything into that folder.

Here's a screenshot of my dock:

enter image description here

The only files in my Downloads folder are OS X generated dotfiles:

➜  ~ ls -A Downloads 
.DS_Store  .localized

A few things that I tried to fix the problem (unsuccessfully):

  • killall Dock
  • repairing permissions
  • rebooting
  • removing the icon from the dock and putting it back in
  • downloading something to see if the new progress would overwrite the problem

How do I get rid of this progress bar that seemingly does nothing but exist?

I'm using Mac OS X 10.8.1 on a MacBook Pro 9,1.

  • Well, Updating to Mac OS X 10.8.2 fixed my problem. I'm still confused how that even happened and how I could get rid of the issue without updating the whole OS (seems like a bit of an overkill). Commented Sep 19, 2012 at 19:45
  • 1
    If this problem appears - I'm on El Capitan btw - the solution that worked for me is this one: (from the terminal) $ defaults write com.apple.dock ResetLaunchPad -bool true; killall Dock
    – thanosa75
    Commented Nov 26, 2015 at 8:56
  • 3
    El Capitan: killall Dock did the trick. Didn't need to do the defaults write ... part. Just had to make sure to capitalize the D in Dock. It didn't work with a lowercase D, even though my system's set up as case insensitive.
    – leanne
    Commented May 23, 2016 at 19:09

10 Answers 10


you don't need to remove/delete the Downloads folder from the dock and re add it, just move it in a new position and the re position it to the old one

  • That is probably better except in the one case (which I had) where it's the only folder there. Commented Apr 14, 2015 at 4:56
  • 3
    Just wiggling it left and right worked for me (10.10.3). Commented Jun 1, 2015 at 15:18
  • 3
    didnt work for me Commented Feb 21, 2016 at 23:37

I removed the folder from the dock and dropped it back on there and it was gone :)

  • 3
    Your solution did work for me.
    – mtsr
    Commented Jan 16, 2014 at 14:43
  • I prefer Dave's answer below- just move it to a new position then move it back
    – arolson101
    Commented Jan 26, 2015 at 21:05
  • For me it resolved the issue just by dragging the downloads item a few pixels and then releasing it.
    – azz
    Commented May 21, 2015 at 14:11

None of the other solutions would solve this for me. The odd part about my issue (that others may or may not have experienced) is that the bar had appeared under the downloads folder yet if I opened different apps the bar would remain in place instead of staying centered under the downloads folder.

What solved it for me was running killall Dock in Terminal.

  • If this doesn't work, killall Finder seems to for me. Commented Mar 8, 2016 at 4:34
  • Just worked again for me in Catalina (macOS 10.15) Beta. Hmm... killall Finder and relaunching the Finder didn't work. And, Catalina wouldn't let me move the Downloads folder (though I could've removed it - didn't try that one).
    – leanne
    Commented Aug 7, 2019 at 21:04

The same happened to me also. Just found out the most simplest of tricks. Just move it anywhere in the dock and the bar disappears.

  • Yep, tried all of the other tricks. As soon as I got hold of it and moved it as much as a pixel, the bar went... I'm getting the feeling it's Chrome related, although none of the other tricks worked, and I don't use Chrome as my main browser (safari).
    – i-CONICA
    Commented Mar 31, 2015 at 16:59

Alright some new information:

It just happened again. I was downloading a MacRuby nightly and my Downloads folder was bouncing more than usually. Looking into the folder I see one of my previous downloads, SENotifier, back in there. It's only 361 KB and the progress bar is at the very beginning.

Here's a screenshot of the Downloads folder.

Clicking on the X doesn't cancel the action (whatever action it's executing) and deleting the file doesn't do anything either, except delete the file, but the problem with the progress bar still remains.

At this point I have to mention that I seem to have deleted the incomplete files yesterday without realizing it. That's why I hadn't included in the initial question. I forgot that I did that.

The solution to my problem:

After a little searching I found out it's a new bug with Chrome Version 23.0.1270.0 dev.

So, that explains that.


I had the same issue. Restarting Chrome did the trick.


I went to Chrome -> Downloads and clicked Clear all

Takes care of it for now.


This is a known bug in Yosemite (and I'm pretty sure it occurred in Mavericks, too). I see it quite often. There are a few Terminal command/logout solutions I've read, but the above suggestions of removing the folder from the Dock and putting it back on will do the trick, and is the fastest solution.


Its not only Chrome - I use Safari with OS Yosemite and had the same problem. All I did was remove/delete the Downloads folder from the dock then re added it.

Job done.

Hope that helps.


Maybe late, but I made a solution. Download free: Restart FinderDock

  • heh - nifty. Thanks for posting the code and the tool!
    – bmike
    Commented Aug 16, 2015 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .