I use OS X 10.8, I type the following

defaults write com.apple.Finder AppleShowAllFiles YES
killall Finder

but still I cannot see any hidden files like .bash_history, .Trash, .cups, .gem etc. in user directory.

5 Answers 5


The bundle identifier is com.apple.finder in lowercase.

defaults write com.apple.Finder AppleShowAllFiles YES would also write the setting as a string, but it doesn't usually matter though.

defaults write com.apple.finder AppleShowAllFiles -bool true
osascript -e 'quit app "Finder"'
  • Worked for me on 10.8.4
    – Kevin Monk
    Aug 16, 2013 at 22:45

Please use defaults read com.apple.finder AppleShowAllFiles to read current status.

Note that it's different to use command with root user (e.g. sudo) or standard user and use com.apple.finder with Finder in lowercase.

For Hide hidden files use defaults write com.apple.finder AppleShowAllFiles 0 from current user terminal window not using sudo or sudo su command.

For Show hidden files use defaults write com.apple.finder AppleShowAllFiles 1

Then relaunch Finder using killall Finder

Tested on OS X 10.8.4.


I had this problem. I tried Lauri's solution, and had intermittent success. I found that my particular problem was that I was sometimes running the command from root. Running it from standard permissions proved consistently successful, where running it from root proved consistently unsuccessful.


I have 2 Macs, both running 10.8.3. I was able to use the

 defaults write com.apple.Finder AppleShowAllFiles YES

suggestion on my Mac Mini with success, but it did not work on the macbook pro no matter how many times (or which method I used) to restart Finder. When I used the "boolean" method, it worked for the macbook the first time. The macbook is a 2010 unit, and the mini from 2012, but all that should be only in the OS, and not related to hardware. very odd, but thanks very much for posting both options. I was beginning to drive myself crazy trying to see hidden files on the laptop. I even used "sudo" for the "AppleShowAllFiles" method, thinking it was a permissions thing, but that did not help.


Use the -boolean option:

defaults write com.apple.Finder AppleShowAllFiles -boolean TRUE
killall Finder

YES is not automatically interpreted as a boolean, but as a string.

  • no..doesn't work: "Unexpected argument TRUE; leaving defaults unchanged. "
    – KMC
    Sep 19, 2012 at 8:40
  • @KMC Ok, what about the -boolean version? Sorry, I have no 10.8 system on which to test.
    – MattiSG
    Sep 19, 2012 at 8:42
  • 1
    same error. I want to go back to 10.6...
    – KMC
    Sep 19, 2012 at 8:51
  • @KMC Which OS X version are you using, 10.6 oder 10.8?
    – nohillside
    Sep 19, 2012 at 9:25
  • 1
    i though my question stated clearly 10.8 (the first line)
    – KMC
    Sep 19, 2012 at 9:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .