Whenever I try to run a Java program with a GUI through Terminal using the `java' command, I get the following error:

2012-09-17 11:37:35.287 java[2486:2617] Error loading /Library/Application Support/SIMBL/Plugins/megazoomer.bundle/Contents/MacOS/megazoomer: dlopen(/Library/Application Support/SIMBL/Plugins/megazoomer.bundle/Contents/MacOS/megazoomer, 265): no suitable image found.  Did find:
/Library/Application Support/SIMBL/Plugins/megazoomer.bundle/Contents/MacOS/megazoomer: no matching architecture in universal wrapper

Note that this doesn't affect the program at all (as far as I know). It compiles and runs fine, but it just blurts out this error as it boots. I tried a bunch of different things, such as re-installing Java or changing permissions for that file, but nothing worked.

I've done some more research in the mean time, and correct me if I'm wrong here, the megazoomer thing has to do with the green magnification button of windows, right?

I run on OS X 8.1, with my Java version being:

java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03-424, mixed mode)

So yeah, if any of you know what this is, what's causing it, and how to fix it, then any and all input would be greatly appreciated!

1 Answer 1


Anything in /Library/Application Support/SIMBL/Plugins has been installed after SIMBL which is is a way of injecting code into a Cocoa app using an Input Manager. SIMBL is a third party add in, the link to megazoomer from the SIMBL page gives a Not found so I would assue it is not maintained.

I would guess the actual error is that megaxoomer does not have a 64 bit Intel version.

Unless you want the extra functions of megazoomer I would delete all the SIMBL plugins ie delete /Library/Application Support/SIMBL and unsinstall SIMBL as per SIMBL docs.

You can run the SIMBL Uninstaller app included with the installer.

Basically unless you know exactly what you are running SIMBL for I would uninstall it.

  • Lucky I always save all my uninstallers, so I don't have to go looking for it. That fixed it for me, thanks a bunch!
    – Fang
    Sep 22, 2012 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .