I have a MacBook Pro and a Mac mini, both running Mountain Lion. This problem, however, started when I had Lion. I can remote in to my MacBook Pro just fine from my iPhone and iPad. But I can't remote into my Mac mini. It started out just fine and I could remote into the Mac mini from my iPhone, iPad as well as my MacBook Pro. Later (I was still on Lion), I could still log in from my iDevices but no longer could from my MacBook Pro. This behavior continued after installing Mountain Lion. Now, I can't remote in from anywhere. I want to avoid doing a clean install, but I will I have to.

I have tried switching from Remote Management under Sharing to Screen Sharing, and back. nothing works. Recently (before I lost the ability to remote in at all, but after I lost the ability to remote in from my MacBook), I also lost the ability to edit my parental controls on the Mac mini from my MacBook. Little by little, I am completely losing the ability to remote in/screen share to my Mac mini at all. Currently, I can only remote in via SSH for a terminal.

My network includes my AirPort Extreme, Time Capsule, MacBook Pro (mid-2010), Mac mini (mid 2010), iPad (3), iPhone 4S, and my father's PC. Only my father's PC is connected by wire. The rest is wireless.

If anyone can guide me in the right direction, I'll be very grateful.

1 Answer 1


Some more info would be helpful here. What app are you using on your iOS devices and Mac to connect to your Mini? What happens when you try to connect—do any errors appear, or does nothing appear to happen?

First off, make sure Screen Sharing is enabled in Sharing Preferences (Remote Management is only for using Apple Remote Desktop, so don't bother with that unless you're actually using that program). Double-check that Allow access is set to either "All Users", or "Only these users" with your user name included in the box.

Now try connecting from another Mac, using the Finder's Connect to Server dialog (under the Go menu, or ⌘K). Under Server Address, type in vnc://IP_OF_YOUR_MINI then hit connect. If you can connect that way, but not using the Finder's Shared panel, then the problem is likely in the Bonjour service that advertises the screen sharing option.

Another thing to check is what version of Apple Remote Desktop Client you have installed. If you have 3.6, there's a bug that can cause timeouts for Screen Sharing/VNC clients. The temporary fix is removing /System/Library/CoreServices/RemoteManagement and re-installing 3.5.3. This worked for me on Lion, I don't know if it will work on Mountain Lion. Make sure to keep a backup copy of the files you delete, in case the install doesn't work.

  • Sorry about that. I did get in a bit of a rush, didn't I? On my iDevices, I use Remoter. It's worked great, plus I can remote in to my dad's PC using RDP if he needs help. When I try to connect through Remoter, it does nothing other than show the message "Connecting..." and it just sits there with no errors. When I try to connect with the Mac, I get "Connection failed to 'Mac mini'." after a few minutes. Thanks for the tip on Remote Management. But I've had no luck with Screen Sharing, either. I'm
    – Winter
    Commented Sep 19, 2012 at 0:46
  • I'm working on the Mac mini with you other suggestions now and I'll report back when I finish.
    – Winter
    Commented Sep 19, 2012 at 0:52
  • Ok, I was running 3.6, and I rolled back to 3.5.3, but I still can't connect. I set the Mac mini back to Screen Sharing instead of Remote Management and tried to connect through Connect to Server. Nothing is working.
    – Winter
    Commented Sep 19, 2012 at 4:06
  • Try enabling the VNC viewers may control screen with password setting (click the Computer Settings… button under Screen Sharing).
    – robmathers
    Commented Sep 19, 2012 at 4:10
  • Did that. Still nothing. It's looking like maybe a clean install. Thanks so much for the help. Any other ideas? I'm willing to try anything to avoid a clean install.
    – Winter
    Commented Sep 19, 2012 at 16:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .