3

I'm having issues with Mountain lion in which I am unable to use my non-Apple keyboard's function keys, i.e. F1, F2 etc. Upon firing up System PreferencesKeyboard, this is what I'm greeted with. enter image description here

In prior versions of the operating system there had been an option here to

Use all F1, F2 keys as standard function keys...

...which enabled me to utilize the Functions keys, as expected, instead of triggering whatever "Hot Key" usually hijacks that binding ordinarily.

enter image description here

How can I get this capability back under 10.8.x?

3

It's still shown for me. Have you tried changing the keyboard type or running defaults write -g com.apple.keyboard.fnState -bool true and logging out and back in?

  • As of 10.8.3.. it's back. I probably did run your defaults command… but don't remember if that's what "fixed it"… so.. you WIN! – alex gray Jun 2 '13 at 0:37
0

I have a Logitech keyboard. In that case, the option in question is not in the preference pane, as you note. But there is an option to set this in the Logitech setup utility. What "non-Apple keyboard" are you using?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .