Revised Question

I am getting errors that mds cannot be started:

9/18/12 9:04:45.262 AM com.apple.launchd[1]: (com.apple.metadata.mds[4720]) Job appears to have crashed: Segmentation fault: 11

Crash Report: PasteBin

Original Question

I ran cd /System/Library/LaunchDaemons sudo launchctl load -w com.apple.metadata.mds.plist which returned com.apple.metadata.mds: Already loaded but when I go to my Activity Monitor and change my filter to All Processes and search for mds I don't see anything, is there a way to force mds to start?

I've tried everything on these sites:

I don't see anything


My guess is that it's launching, then crashing or erroring out in some form. Try sudo launchctl list com.apple.metadata.mds, and look at the PID (id of currently running process, probably 0 since it's not running) and LastExitStatus (which would be 0 if it exited successfully, but may be something else in this case). Also, look at /var/log/system.log (with either Console.app or 'tail') and see if it holds any clues. Also, look in /Library/Logs/CrashReporter for any relevant reports.

As for possible causes: if the logs don't tell you where the problem is, my first guess would be a broken mdimporter plug-in; I'd remove everything (temporarily) from /Library/Spotlight and ~/Library/Spotlight. Also, check /System/Library/Spotlight, and make sure these are the only mdimporters there:

Application Archives Audio Automator Bookmarks Chat CoreMedia Font Image MIDI Mail Notes PDF PS QuartzComposer RichText SystemPrefs iCal iPhoto iPhoto8 vCard

Another possible cause is a badly corrupted spotlight database. If removing suspect mdimporters doesn't get it started, try dismounting everything but the startup volume (& if that solves it, remount them one at a time and see which kills it). If that doesn't do it, try removing the existing spotlight database with sudo mv /.Spotlight-V100 /.Spotlight-V100-disabled (I'm not certain how thoroughly sudo mdutil -E / wipes out the old DB, but renaming it should force a full rebuild).

  • 1
    +1 for moving the Spotlight database. Note that each drive will have its own, so you might wish to eject all the non-System volumes as a step in your troubleshooting. That, or rename them too (eg: sudo mv /Volumes/LacieDrive/.Spotlight-V100 .Spotlight-V100-disabled ) – username Sep 18 '12 at 4:20
  • This has gotten me closer, I will revise my question to reflect. – cynicaljoy Sep 18 '12 at 12:57
  • And now I am going to jump out a window. There was a USB key that I forgot that I plugged in, as soon as I removed it Spotlight started reindexing. – cynicaljoy Sep 18 '12 at 13:14
  • 1
    Probably a damaged spotlight DB on that USB key, then. You should be able to reset it with either sudo mdutil -E /Volumes/drivename or sudo mv /Volumes/drivename/.Spotlight-V100 /Volumes/drivename/.Spotlight-V100-disabled – Gordon Davisson Sep 18 '12 at 15:29

The LaunchDaemon "com.apple.metadata.mds.plist" tells the system to run the following program: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Support/mds

Do you have that file on your system?

If so, you should check Console.app to see what error messages are being thrown (when the LaunchDaemon attempts to start it).

You should also compare the version of the following framework (note that it's one of the parent folders of the the mds file above) in Finder:


I'm running OS X 10.7.1, and my version (right-click the framework, and choose "Get Info") says 10.7.0

You might also be able to see if the system is attempting to launch it, by running "sudo newproc.d" in Terminal. This command should show you requests (including flags) to start processes, so you'll probably notice the "mds" command showing up there.


must haves in your ~/.bash_aliases file.
or just use the ='CMD' at the terminal, as needed.

start/stop indexing on all volumes

alias spotlightoff='sudo mdutil -a -i off'
alias spotlighton='sudo mdutil -a -i on'

load / unload spotlight Launch Daemons.

alias spotlightunload='sudo launchctl unload -w \
alias spotlightload='sudo launchctl load -w \

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .