2

I don't know why, but about a week ago I started seeing a lot of errors like this in system.log:

9/15/12 5:55:21.769 AM Alfred[263]: DB Query: select item, count(item) as used from knowledge where ts > ? and item in (?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?) group by item
9/15/12 5:55:21.769 AM Alfred[263]: DB Error: 11 "database disk image is malformed"

It would occasionally take about a second for files to show up in the result list.

Deleting the Spotlight index didn't help, but then I noticed that the usage tab didn't display any statistics either:

I think I solved it by just pressing the reset knowledge button. But I didn't find search results for this issue, so I'm answering this question myself.

2

So, pressing the reset knowledge button in the preferences seems to have fixed it.

If you get similar errors, you could also try removing ~/Library/Application Support/Alfred/knowledge.alfdb or other database files. If you're using a sandboxed version bought from the App Store, they are in ~/Library/Containers/com.alfredapp.Alfred/Data/.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .