I changed the default mail client to Sparrow yet every time I try to decline a calendar invite, Mail.app launches to send the decline message.

Any ideas?

  • Could you detail the steps you followed to set the default mail client as well as whether you have iCal set to retrieve CalDAV from Mail in the iCal settings? (it's probably an iCal bug / unwelcome feature but I could try to reproduce things with more details) – bmike Sep 17 '12 at 17:45
  • I launch the regular mail.app and go into preferences. I set the default mail client to sparrow. Then I close mail.app. When a meeting is in my calendar and I decline it, it attempts to send the decline message by opening mail.app to send it for some reason. All other aspects of mail defaulting away from mail.app work. – Jody G Sep 19 '12 at 13:23
  • Short of disabling the switch to retrieve invitations from Mail you might be faced with filing a bug report with Apple or getting a new calendar app. BusyCal is one I really like for many reasons. – bmike Sep 19 '12 at 13:26

You must log in to answer this question.

Browse other questions tagged .