I had an Eclipse environment all wrong, than I decided to install another (newer) version from scratch. After I "uninstalled" the older version, I downloaded the Eclipse for Java Developers 64-bit for OS X (version 3.8) from eclipse.org.

After I downloaded, I tried to open and the error Eclipse quit unexpectedly begun to haunt my programming fun! Does anyone have a solution for that problem?

These are the ones I've tried:

  1. Clean the workspace.
  2. Open via Terminal with -clean.
  3. Download previous "working" version.
  4. Downloaded other version.

RESULT: same problem = eclipse quit unexpectedly.

  • 3
    Create a new workspace. Sep 24, 2012 at 20:26
  • @ThorbjørnRavnAndersen you should make that an answer explaining how to do it
    – dstarh
    Dec 16, 2014 at 20:45

8 Answers 8


This is probably because eclipse shutdown abnormally. Open the Terminal and go to the location where eclipse is installed.

cd /Applications/Eclipse.app/Contents/MacOS

Then run eclipse from the terminal like...

./eclipse -clean

It should start, once it does go to the Eclipse menu and Quit eclipse.

If you have any shortcuts on the desktop you'll have to remove them and make new shortcuts with the executable.

  • Only this solution worked for me - Thanks #David!
    – sean2078
    Dec 8, 2015 at 21:54

I had the same problem on my Mac running OS X Mountain Lion 10.8.2.

I tried:

  1. Installing/updating to the newest version of Sun Java.
  2. Re-downloading a different Eclipse Package.
  3. Re-installing Eclipse.

None of these things worked. I was using The Unarchiver 3.3 to unarchive the tar.gz archive—this was the problem. I right clicked the archive and selected Open With → Archive Utility.app (10.8). Then I dragged the unarchived folder to Applications and now Eclipse runs. Seems The Unarchiver was corrupting a file. Very strange, The Unarchiver has never let me down before but this seems to be the problem.

  • Get the latest version of The Unarchiver from the App Store then. An older version is known to corrupt files on extract under certain circumstances.
    – nohillside
    Oct 14, 2012 at 12:44

I had same problem , But after doing all mentioned above there is no benefit. Then I find out that the reason is I am trying to run Eclipse from a shortcut link, so I delete that and then back to Eclipse root folder and make an Alias from the Eclipse file and then I send it to desktop and now running very well.


I also received the "Eclipse quite unexpectedly" error after following the Application drop described at http://developer.xamarin.com/guides/cross-platform/ci/configuring_tfs/. Instead of running the eclipse app from the Applications folder, simply run it from the original "eclipse" folder to avoid the error.


In my case, I got this error, when I moved only eclipse shortcut to application folder. I solved this by moving whole eclipse folder(not the eclipse shortcut/eclipse executable) to application.


Had the same issue. To solve it, I had to remove the "eclipse" executable in the application folder and replace it with a link to the one inside the Eclipse.app folder

rm eclipse
ln -s $PWD/Eclipse.app/Contents/MacOS/eclipse eclipse

Hope it helps !


Not sure what uncrompression program do you use, but please don't use "The Unarchiver" when you expand eclipse tar.gz file. There's a bug in "The Unarchiver" program on the mac that causes this issue to happen. see: https://bugs.eclipse.org/bugs/show_bug.cgi?id=305758

  • 2
    The referenced bug is two years old. Current versions of "The Unarchiver" should work ok and are available in the Mac App Store.
    – nohillside
    Sep 24, 2012 at 20:30

Reinstalling Eclipse solved the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .