My iPhone 4 runs iOS 5.1.1.

When I go to settings > iCloud, the Photostream option is not available. I've tried to restore my phone, but the option is still not available.

enter image description here

How can I activate this setting when it's missing from the preference?

  • Same problem here with my iPhone 4S on Sprint...both the Photo Stream and Documents options are not available in Settings -> iCloud. My wife also has an iPhone 4S on Verizon with no issues. – Kevin Higgins Sep 18 '12 at 2:13
  • Can you delete this account from the phone and perhaps try another account? Also - the troubleshooting article mentions that you can sign into iCloud on a computer and reset all the photos. Can you at least see the reset option if you don't want to reset everything to a clean slate and try again setting it up on the device. support.apple.com/kb/HT4486 – bmike Sep 18 '12 at 2:35
  • thanks for that. unfortunately it didn't solve my issue. I'm thinking: this is my professional phone. Is there a way for my employer to lock down this feature through the application of a profile (I know they use one e.g. for setting password policy)? – Pierre Sep 18 '12 at 4:57
  • 2
    Pierre...that might be it (my phone is a work-supplied as well). Maybe they're limiting our bandwidth usage?? I'll ping my tech support today. – Kevin Higgins Sep 18 '12 at 12:46

Just looked a little closer at my settings.... Settings -> General -> Profiles -> [Work Profile] -> More Details -> Disable Documents in the Cloud, iCloud backup, Photo Stream.

There's my answer, my company supplied configuration that was loaded on the phone limits this option.

C'est la vie...

  • Great answer - profiles can restrict a ton of options. – bmike Sep 18 '12 at 13:05
  • Bingo! I have the same limitation. Thanks a ton for your investigations! – Pierre Sep 18 '12 at 13:53

Photos are no longer in the CAMERA. They are in the Photos. (the blue background with the flower).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .